Author Topic: symbol lookup error  (Read 6956 times)

ahanganu

  • Guest
symbol lookup error
« on: March 03, 2009, 03:48:34 pm »
Hi all,

I've been compiling and trying to run codeblocks from the svn trunk for some time now (couple of weeks).
I'm compiling it on a gentoo linux amd64 with gcc (GCC) 4.1.2 (Gentoo 4.1.2 p1.0.2).
Last revision i've tryed to compile and run is 5475, latest one in the trunk at this moment.

All compiling works smoothly, after make install i try to start codeblocks and it crashes:

/usr/local/bin/codeblocks: symbol lookup error: /usr/local/bin/codeblocks: undefined symbol: _Z12cbLoadBitmapRK8wxString12wxBitmapType

On the other side, the gentoo package from portage is working fine.

I imagine it must be a wrong library version or something, but i could not find anything related to that symbol over the net, any suggestions would be greatly appreciated.

Andrei

snaps

  • Guest
Re: symbol lookup error
« Reply #1 on: March 22, 2009, 08:29:42 am »
Hi Andrei,

I ran into this error message, I just needed to follow the last section of the instructions on the wiki

http://wiki.codeblocks.org/index.php?title=Installing_Code::Blocks_from_source_on_Linux

and add '/usr/local/lib' to my /etc/ld.so.conf file.

Cheers,

Tom

Offline Alcareru

  • Single posting newcomer
  • *
  • Posts: 5
Re: symbol lookup error
« Reply #2 on: May 24, 2009, 09:21:24 pm »
and run:
sudo ldconfig
(or drop the sude if your already root)

Offline shoop

  • Single posting newcomer
  • *
  • Posts: 3
Re: symbol lookup error
« Reply #3 on: October 02, 2009, 01:49:13 pm »
Actually, the ld.so.conf file already included the correct path for me, I just had to run ldconfig