Author Topic: problem compiling  (Read 2319 times)

Offline stufava

  • Single posting newcomer
  • *
  • Posts: 9
problem compiling
« on: February 05, 2009, 03:38:07 pm »
Hi to everyone,
I wrote the source code of a project i have to make for an exam.
If i simply open the file of the source code (main.cpp) and i try to build, the build log gives me this error:

Code: [Select]
[color=red]Process terminated with status 1 (0 minutes, 1 seconds)
0 errors, 0 warnings[/color]

I'm a beginner with Code::Blocks and C++, i've just made simple programs, usually compiling single files; but looking for a solution for this problem i was told to open a new project (console application) and to copy the source code in the main file of the project: i've done these things and now, when i try to build, the build log gives me this error:

Code: [Select]
[color=blue]"project - Debug" uses an invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!]. Skipping...[/color]
Nothing to be done.

Can anybody help me??
Sorry for the english...
P.s.: I have Code::Blocks 8.02, compiler MinGW, SO Windows XP
Thanks!!

Offline mmkider

  • Almost regular
  • **
  • Posts: 150
Re: problem compiling
« Reply #1 on: February 05, 2009, 03:45:26 pm »
Check this item
          Settings->compiler and debuger->Global compiler settings->Toolchain executables

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7253
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: problem compiling
« Reply #2 on: February 05, 2009, 03:47:03 pm »
As first use the forums search before asking.

This questions has been answered quite often

You most likely do not have a compiler or your compiler toolchain is not set correctly.

Topic locked.