Recent Posts

Pages: 1 ... 3 4 5 6 7 [8] 9 10
71
General (but related to Code::Blocks) / Re: Breakpoints in assembly code
« Last post by druizm on May 13, 2019, 09:47:23 am »
If I execute "info breakpoints" from the Debugger tab (during debugging), I receive this information:
Quote
> info breakpoints
Num     Type           Disp Enb Address            What
1       breakpoint     keep y   0x00007ffff7b32920 exception throw
2       breakpoint     keep y   0x00000000004005c1 /root/CodeBlocks-workspace/Test/assembler.asm:21
   breakpoint already hit 1 time
In arand.cont () ()
#2  0x0000000000400668 in main () at /root/CodeBlocks-workspace/Test/Test-manual-Tomas.c:25
/root/CodeBlocks-workspace/Test/Test-manual-Tomas.c:25:483:beg:0x400668
At /root/CodeBlocks-workspace/Test/Test-manual-Tomas.c:25

So it seems debugger detects correctly breakpoint located within the asm file, but execution stops at C code and not jumps to ASM code, so F7 (Next Line) execute all line in asm code but remains at the same line in C code (it's a function in assembler code), so I can't debug line-by-line after breakpoint inside the asm code.

I can't know if nasm is producting compatible debug symbols. My CodeBlocks configuration for asm file is this:
Quote
Command line macro:
nasm -g -f elf64 -o obj/Debug/$file_name.o $file

so I suppose nasm is generating compatible debug symbols.

I'm running CodeBlocks 17.12 in a CentOS-7_x86_64

Thanksk.
72
Help / Re: Cant create Project
« Last post by oBFusCATed on May 13, 2019, 09:04:35 am »
Reinstall, but this time enable the scripting wizard plugin...
73
Help / Cant create Project
« Last post by redzen1201 on May 13, 2019, 05:14:59 am »
hello guys im new here.. i have problem when im done installing the codeblocks and create new project, every time i click New project there is nothing but just a blank panel without option or type of project. i just follow the installation on youtube, please help  :-[

im using windows 8.1

see attachment.
74
Development / Re: Problem with icons on HiDPI displays
« Last post by oBFusCATed on May 12, 2019, 11:48:13 pm »
Bleh, I guess dash doesn't support source. :(

Can you replace it with either (note the dot at the beginning)
Code: [Select]
. ./update

or just
Code: [Select]
./update

And tell me which works for you?
75
Hello.

What I'm trying to report is that it appears to be a bug that prevents compilation errors from being reported correctly in the editor in the CodeBlocks IDE, in the following specific case.

It happens only when using Menu - Build - "Compile current file" and not when using Build or Rebuild - the other compiling methods. Additionally, the project compiler must be set to different than the Target compiler, in the Project Build Options window.

To summarize, following is needed:
1. Using Menu - Build - "Compile current file"
2. Project compiler set to different than Target compiler.

In my case specifically, what I have set is the "*Np Compiler*" compiler as Project compiler and the "GNU GCC Compiler" compiler as the Target compiler. I have tested this on my customized CodeBlocks IDE v17.12 for Windows and on the 20 April 2019 build  - it appears it persists there too. Please check attached screenshot animation below (about 46s long).


https://drive.google.com/file/d/1GDRz9m48bIihCaUU7zkJnQbVok34Jj38/view?usp=sharing
76
Development / Re: Problem with icons on HiDPI displays
« Last post by BlueHazzard on May 12, 2019, 10:59:09 pm »
linux mint 18
if i run ./update30 i get
Code: [Select]
codeblocks_sf/src$ ./update30
./update30: 2: ./update30: source: not found

and for
./update
Code: [Select]
codeblocks_sf/src$ ./update
Updating Linux version.
./update: 26: ./update: Syntax error: "(" unexpected (expecting "}")

I had to replace the first line with
Code: [Select]
#!/bin/bash
77
Development / Re: Compiling SpellChecker on linux
« Last post by BlueHazzard on May 12, 2019, 09:23:26 pm »
Ping.

Can some other on linux check if he has the same problem with compiling spell checker with codeblocks?
78
Then why don't you just write a cbIspuncUtf8 and be done with it?
79
The problem is that utf8 does not work on windows and we use utf8 everywhere (what is the only right thing to do).  wxIspunc uses the system function std::iswpunc and this function is not really nice specified by the standard... So the word splitting won't work on windows if we do not convert it to utf16 when we want to use some unicode aware functionality. And what i can tell, for wxIspunc (aka std::iswpunc) also the local is crucial, because as i noted top, with my locale, russian characters are not detected correctly...
80
Using Code::Blocks / Re: Length of selected text
« Last post by zdena on May 12, 2019, 11:08:23 am »
@BlueHazzard: It was whole morning fight. I lost the battle with automatic patching :( , but I solved it manually :) . Next the C::B sources compiling was hard - especially battle with libexchndl.
But the result: Yes, your solution works pretty good  ;) Thank you
Pages: 1 ... 3 4 5 6 7 [8] 9 10