Recent Posts

Pages: 1 2 [3] 4 5 6 7 8 ... 10
Chrome and Firefox are build with clang now, so if they could be built, everything could be built.

@bluehazzard: I think you've tested this and haven't reported any problems. :(
I am using centos 8. I have installed CodeBlocks recently using flatpak.
Using codeblocks from flatpak doesn't work.
Vanilla codeblocks requires major changes to make it actually work.
If you have problem with a flatpak version of Code::Blocks please report them to the vendor which made the flatpak.
He/she/it is doing major hacks to make it work.
Help / Re: FLUID and mouse selection
« Last post by BlueHazzard on Yesterday at 08:46:31 pm »
For me normal environment, all plugins enabled (not so recent) trunk build, windows 10
Keyboard shortcuts using the number pad are now disallowed.
Rev: 12165.

It's a bug that they ever were allowed.

A pity. I was thinking of it as a feature  :)
It was just fine in the days when wxWidgets produced a numeric ascii char for the numpad keys, but wxWidgets is now producing a 2byte unicode char which will not work for accelerators.
Help / Re: FLUID and mouse selection
« Last post by Pecan on Yesterday at 08:04:15 pm »
Are you running a clip board (cut/paste) handler in the background?

Would you disable the plugins one at a time to see if disabling one solves the problem.

Would you list for us, the plugins you are running so we can try to create an environment like yours to test with.
Probably this can help too

1) I wonder if it would be possible to run the host compiler with this command. For sure hell of imperformat but it could work
2) I wonder what compiler the flatpack uses
3) I wonder if you can use system libraries within the flatpack codeblocks...

Where did you get the codeblocks flatpack?
I have no unix system at the hand at the moment, so i do not know if you can add "free" terminals. if so, you can try to put
Code: [Select]
flatpak-spawn --host in front of it

But i do not know if you have to modify some permissions (i suspect so)
I do not know many things about flatpack and i do not think that we provide a official release with it?

Isn't flatpack isolating the executable from the outside operating system in a sandbox, so you can not run anything from the outside of this sandbox
as long as you do not add it specifically in your application? So i do not think this is possible in a quick way...
Nightly builds / Re: The 21 May2020 build (12091) is out.
« Last post by ccdric on Yesterday at 03:34:42 pm »
try to build this rev with  vx3.2.3 gtk3 from codelite repo on Ubuntu 20.04.

[email protected]:$ sudo update-alternatives --config wx-config
Il existe 5 choix pour l'alternative wx-config (qui fournit /usr/bin/wx-config).

  Sélection   Chemin                                                            Priorité  État
  0            /usr/lib/x86_64-linux-gnu/wx/config/gtk3-unicode-3.1-unofficial3   318       mode automatique
  1            /usr/lib/x86_64-linux-gnu/wx/config/base-unicode-3.0               306       mode manuel
  2            /usr/lib/x86_64-linux-gnu/wx/config/base-unicode-3.1-unofficial    317       mode manuel
  3            /usr/lib/x86_64-linux-gnu/wx/config/gtk2-unicode-3.1-unofficial    318       mode manuel
  4            /usr/lib/x86_64-linux-gnu/wx/config/gtk3-unicode-3.0               309       mode manuel
* 5            /usr/lib/x86_64-linux-gnu/wx/config/gtk3-unicode-3.1-unofficial3   318       mode manuel
after :

svn up -r 12091

an error occurs in dpkg-buildpkg :
[email protected]:$ dpkg-buildpackage -us -uc
dpkg-buildpackage: info: paquet source codeblocks
dpkg-buildpackage: info: version source 20.03svn12091
dpkg-buildpackage: info: distribution source UNRELEASED
dpkg-buildpackage: info: source changé par cedric <[email protected]>
dpkg-buildpackage: info: architecture hôte amd64
 dpkg-source --before-build .
dpkg-checkbuilddeps: error: Unmet build dependencies: libwxgtk2.8-dev | libwxgtk3.0-dev
dpkg-buildpackage: avertissement: dépendances de construction et conflits non satisfaits ; échec.
dpkg-buildpackage: avertissement: (Utilisez l'option -d pour forcer.)

 strange the original wxlib 3.0 from ubuntu20.04  is also installed  :

[email protected]:$ dpkg -l | grep libwxgtk3.0
ii  libwxgtk3.0-gtk3-0v5:amd64                                  3.0.4+dfsg-15build1                        amd64        wxWidgets Cross-platform C++ GUI toolkit (GTK 3 runtime)
ii  libwxgtk3.0-gtk3-dev:amd64                                  3.0.4+dfsg-15build1                        amd64        wxWidgets Cross-platform C++ GUI toolkit (GTK 3 development)

anybody can help me ?
I am using centos 8. I have installed CodeBlocks recently using flatpak. Everything is working perfect. I want to change the default xterm terminal. I tried to change it from Environment but didn't work. Here are some details about my installation-

[[email protected] bin]$ pwd
[[email protected] bin]$ ls
cb_console_runner  codeblocks  resize  xterm
cb_share_config    koi8rxterm  uxterm

As you can see the path of the installation folder and there is no terminal here expect xterm

When I run a simple hello world program, the build log prints
Executing: 'gnome-terminal -t '/home/praj/Desktop/Prog/hello11' -x  '/app/bin/cb_console_runner' '/home/praj/Desktop/Prog/hello11'' (in '/home/praj/Desktop/Prog')
Process terminated with status -1 (0 minute(s), 3 second(s))

I have tried everything I found on the internet. Could anyone help me?
Pages: 1 2 [3] 4 5 6 7 8 ... 10