Code::Blocks

User forums => Using Code::Blocks => Topic started by: John on September 28, 2005, 05:19:01 pm

Title: Typing russian letters in C::B
Post by: John on September 28, 2005, 05:19:01 pm
Hi. I've just built & installed C::B on RedHat 9. The problem is I can't type russian letters in editor properly. Namely I can see the letters typed but the cursor & other typed text do it much worse than me: the cursor sticks on it and the text overwrite it (visually). Beside russian text is typed using other (very strange) font. Anyone can suggest me what sould I do next to cope with it?
Thanks in advance.
Title: Re: Typing russian letters in C::B
Post by: mandrav on September 28, 2005, 06:38:42 pm
Maybe changing the editor's font can help?
Title: Re: Typing russian letters in C::B
Post by: Urxae on September 28, 2005, 07:23:59 pm
What version of C::B did you build? Did you enable unicode?
Title: Re: Typing russian letters in C::B
Post by: John on September 29, 2005, 12:25:12 pm
I used 'codeblocks-1.0-rcl-1.tar.gz'. I didn't enable unicode. Should I? What is the way?
Title: Re: Typing russian letters in C::B
Post by: Urxae on September 29, 2005, 01:39:17 pm
IIRC RC1 doesn't entirely work with unicode, but the current CVS version should work. See the wiki article (http://wiki.codeblocks.org/index.php/Installing_Code::Blocks) on how to install it. I'm not sure if unicode is enabled by default, so in the 'configure' step first run
Code: [Select]
./configure --help to see what command-line option enables it (if necessary).

Alternatively, you could wait for RC2 to come out. Not sure exactly when that'll happen, but they've been promising to release it for some time now ;).
Title: Re: Typing russian letters in C::B
Post by: John on September 29, 2005, 02:02:01 pm
Maybe changing the editor's font can help?

Nope. I feel like it doesn't matter.
Title: Re: Typing russian letters in C::B
Post by: mandrav on September 29, 2005, 02:52:44 pm
You have to use the unicode build.
C::B is already unicode-aware (the CVS version).
You just have to use a unicode build of wxWidgets (and build C::B with it).
Title: Re: Typing russian letters in C::B
Post by: John on September 29, 2005, 06:11:20 pm
Thank you all guys. I am trying to ... We'll see.
Title: First troubles
Post by: John on September 30, 2005, 03:26:44 pm
Well, it finally works. Do it work with gdb properly? That is I have in "GDB debugger (debug)" window when trying to watch something:

> info args
262611211111511645112114111109112116
78111329711410311710910111011611546
262611211410145112114111109112116
40103100984132
2626112114111109112116

Is it a bug for now?

And the other question is: It seems than ctrl key doesn't affect anything when functional (F*) keys are pressed. That is, ctrl+F9 works just like ordinary F9.
Is it a bug for now?

Thanks in advance.
Title: Re: Typing russian letters in C::B
Post by: rickg22 on September 30, 2005, 06:31:43 pm
Yikes! Yes, it seems you found an unicode bug in the GDB plugin. Please report it.
Title: Re: Typing russian letters in C::B
Post by: John on October 04, 2005, 09:28:29 am
Yikes! Yes, it seems you found an unicode bug in the GDB plugin. Please report it.
How can I report it?
Title: Re: Typing russian letters in C::B
Post by: rickg22 on October 04, 2005, 06:42:13 pm
Go to the www.codeblocks.org page, and on the left menu, there's an item that says "report a bug".