Code::Blocks

User forums => Embedded development => Topic started by: Rotule on October 07, 2008, 07:19:34 pm

Title: Tricole TC1766 using infineon's DAVE software and c::b
Post by: Rotule on October 07, 2008, 07:19:34 pm
Fisrt of all , Hi everybody.

I am new to this forum and also with C::B

i am currently working on a embedded project using the tricore TC1766 from infineon.

I have the tricore PxRos deveopment platform wich include codeblocks and the tricore compiler.

What i am trying to do for now i to get the example for interrupts working and nothing seems to work.
the example in Dave Quickstart.pdf include a flashjing led with nop and a infinite loop in the main, the led start flashing when the controller boot's but after less than a second, the led stop flashing, i think the controller completely stop working,

if anyone can help, i can send my Dave and codeblocks project.

if you need more information, just ask and i will answer back as soon as possible.

Thank you.

Francois Rainville.

Title: Re: Tricole TC1766 using infineon's DAVE software and c::b
Post by: mariocup on October 07, 2008, 08:17:42 pm
Hi Rotule,

this is a TriCore and not a CB related question. I will have a look at your example.

Bye,

Mario
Title: Re: Tricole TC1766 using infineon's DAVE software and c::b
Post by: Rotule on October 07, 2008, 11:17:06 pm
Sorry, Can you tell me where i can find some tricore applicated forums ? if you know some.

Thank you
Title: Re: Tricole TC1766 using infineon's DAVE software and c::b
Post by: mariocup on October 08, 2008, 08:05:02 am
Hi Rotule,

sorry, it exists only a german TriCore forum (http://www.mikrocontroller.net/forum/mikrocontroller-elektronik/tricore).

Bye,

Mario
Title: Re: Tricole TC1766 using infineon's DAVE software and c::b
Post by: rgledhill on October 08, 2008, 05:10:28 pm
Hi,

There is also an English-speaking forum here:

http://tech.groups.yahoo.com/group/tricore/

Your problem sounds like the Watchdog is still on...  make sure you disable the Watchdog!  You need to go into the SCU part of DAvE, ensure "Disable the Watchdog Timer" is ticked, and then go to the Functions tab and make sure SCU_VInit is ticked.

Best regards
Richard
---
Hitex Design  --  www.hitexdesign.com
Title: Re: Tricole TC1766 using infineon's DAVE software and c::b
Post by: Rotule on October 09, 2008, 06:54:51 am
Thank you all, i got some help from Hightec, the problem was that i was using the default linker script, now my project is working flawlessly. ... that was a newby problem ;)
Title: Re: Tricole TC1766 using infineon's DAVE software and c::b
Post by: rgledhill on October 09, 2008, 09:52:16 am
Ah, no problem!  Hightec are very good with their support so I'm glad they could help  :D