Code::Blocks

Developer forums (C::B DEVELOPMENT STRICTLY!) => Plugins development => Topic started by: jberko on September 01, 2008, 12:01:10 pm

Title: wxSmith "add wxPanel" has improper panel names
Post by: jberko on September 01, 2008, 12:01:10 pm
I have a wxNotebook with several named pages, and chose to use the menu choice in CB of "wxSmith|add wxPanel" to create the pages so they would reside in separate files with the same name as the notebook pages.  My application works fine, but if I use the GetCurrentPage() function and then GetName() inside a wxNotebookEvent function that checks when a page has been changed, all my pages have the name "id".  I can see that in each separate page (wxPanel) file, the Create() function for the wxPanel gives all the pages the name "id" as the last parameter in the function, but in the text of the corresponding "wxs" file, the name is listed correctly on the line that reads "<object class="wxPanel" name="FooPanel">.  In this case, I believe the Create function should be using the name "FooPanel" to name the wxPanel, rather than using the generic name "id".  Please tell me if the way wxSmith currently works with regard to naming these panels is as intended, because now I do not have a way of telling what notebook page I have changed to.
Title: Re: wxSmith "add wxPanel" has improper panel names
Post by: byo on September 03, 2008, 10:40:40 pm
Hmm, I didn't notice that bug before :)
Thanks for reporting, I'll try to fix this soon.

Regards
   BYO