Code::Blocks

User forums => Using Code::Blocks => Topic started by: grv575 on September 02, 2005, 08:04:45 pm

Title: backticks `wx-config --cflags`
Post by: grv575 on September 02, 2005, 08:04:45 pm
http://sourceforge.net/tracker/?func=add&group_id=126998&atid=707416

`wx-config --cflags` doesn't work when compiler is invoked directly.  this has something to do with how the compiler is executed.

system("command");

would solve this.  calling the compiler using system() correctly passes the command to the underlying OS shell which handles "" in pathnames, spaces, eval() type stuff (like `s).

Not sure if all environments/OSes support this properly.
Should be looked into
Title: Re: backticks `wx-config --cflags`
Post by: guru on September 13, 2005, 12:22:54 am
I was wondering if this is likely to be fixed soon as I have some serious problems getting my projects to link without using library scripts. or is there a workaround?

thanks for any suggestions/info and keep up the good work!
Title: Re: backticks `wx-config --cflags`
Post by: rickg22 on September 13, 2005, 01:13:09 am
You can as well compile using makefiles. There's an option in the compiler settings.
Title: Re: backticks `wx-config --cflags`
Post by: mandrav on September 13, 2005, 08:16:43 am
Go to Settings->Compiler->Other and set the build mode to "GNU make". Backticks work with it.
Title: Re: backticks `wx-config --cflags`
Post by: guru on September 13, 2005, 02:15:08 pm
thanks a buch for the quick and helpfull replies! it works like a charm now, both using a custom makefile and adding library scripts.
Title: Re: backticks `wx-config --cflags`
Post by: rickg22 on September 13, 2005, 04:37:26 pm
I suppose you're working on your Indiana Jones game (http://www.amberfisharts.com/), tell us when it's playable! ;-)