Code::Blocks

User forums => General (but related to Code::Blocks) => Topic started by: jmccay on May 17, 2007, 02:59:34 am

Title: GCC 4.2
Post by: jmccay on May 17, 2007, 02:59:34 am
GCC 4.2 has been released (May 13, 2007).  http://gcc.gnu.org/gcc-4.2/ (http://gcc.gnu.org/gcc-4.2/)  Has anyone tried it yet?  GCC 4.2 was supposed to be the first release that included the patch to fix the many errors produced when compiling wxWidgets.

jmccay
Title: Re: GCC 4.2
Post by: TDragon on May 17, 2007, 03:21:22 am
GCC 4.2 was supposed to be the first release that included the patch to fix the many errors produced when compiling wxWidgets.
Where did you hear this? And for that matter, what do you mean by many errors? wxWidgets compiles with many warnings, but only a few errors with an unpatched GCC 4. Most of the warnings are gone when you use "-Wno-attributes".

At any rate, I have built GCC 4.2 (look for a link in my sig sometime in the next few days), and it does still require a patch in order to compile wxWidgets successfully.
Title: Re: GCC 4.2
Post by: stahta01 on May 17, 2007, 03:42:32 am
GCC 4.2 was supposed to be the first release that included the patch to fix the many errors produced when compiling wxWidgets.

GCC 4.2 was supposed to the first of the GCC 4 line that the minGW team thought worth trying to get it working as an minGW built product.

GCC 4.3 is supposed to the first of the GCC 4 line that supports minGW as an secondary platform. This should mean that no patches should be needed to make minGW version of GCC 4.3.

Tim S
Title: Re: GCC 4.2
Post by: jmccay on May 22, 2007, 01:15:36 am
GCC 4.2 was supposed to be the first release that included the patch to fix the many errors produced when compiling wxWidgets.
Where did you hear this? And for that matter, what do you mean by many errors? wxWidgets compiles with many warnings, but only a few errors with an unpatched GCC 4. Most of the warnings are gone when you use "-Wno-attributes".

At any rate, I have built GCC 4.2 (look for a link in my sig sometime in the next few days), and it does still require a patch in order to compile wxWidgets successfully.

I meant the warnings.  I have not tried GCC 4.  There was a patch (issue: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=20345  patch {from the bottom of the page}: http://gcc.gnu.org/ml/gcc-patches/2006-06/msg01511.html).  That was supposed to fix the "type attributes are honored only at type definition" warning problem.  I had previous mentioned in a previous post the patch http://forums.codeblocks.org/index.php/topic,3422.15.html.  I probably should mentioned the previous post in my post.

jmccay
Title: Re: GCC 4.2
Post by: TDragon on May 22, 2007, 01:23:11 am
The specific warning you refer to is gone, but further warnings still remain (some of which, as before, can be disabled with -Wno-attributes).
Title: Re: GCC 4.2
Post by: snija on May 24, 2007, 06:19:29 am
hi, dear 20-40, could you please make a libgomp.a which static links to pthread-win32 static lib (make make clean GC-static)?
thank you.
Title: Re: GCC 4.2
Post by: snija on May 24, 2007, 03:46:14 pm
That`s cool, thank you very much, now for small program i need not to distribute pthreadGC2.dll with it.
It works well with pthread_win32_process_attach_np () and pthread_win32_process_deattach_np ().
Title: Re: GCC 4.2
Post by: snija on May 25, 2007, 03:13:20 am
Does anyone know the x86_64-pc-mingw32 build (not only headers)?