Code::Blocks

User forums => Nightly builds => Topic started by: killerbot on May 01, 2007, 07:52:56 pm

Title: The 01 May 2007 build is out.
Post by: killerbot on May 01, 2007, 07:52:56 pm
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

A link to the unicode windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw28u_gcc_cb_wx283.7z


For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://prdownload.berlios.de/codeblocks/mingwm10.7z

The 01 May 2007 build is out.
  - Windows :
   http://prdownload.berlios.de/codeblocks/CB_20070501_rev3915_win32.7z
  - Linux :
   http://prdownload.berlios.de/codeblocks/CB_20070501_rev3915_Ubuntu6.xx.deb
   http://prdownload.berlios.de/codeblocks/CB_20070501_rev3915_suse100-102.i586.rpm (not yet)
   http://prdownload.berlios.de/codeblocks/CB_20070501_rev3915_fc4+5.i586.rpm (not yet)


Resolved Fixed:


Regressions/Confirmed/Annoying/Common bugs:


Title: Re: The 01 May 2007 build is out.
Post by: Xaviou on May 01, 2007, 09:11:09 pm
Ubuntu 6.10 & 7.04 Amd64 .deb installer can be found here (http://www.esnips.com/web/CodeBlocks).
Title: Re: The 01 May 2007 build is out.
Post by: Steven 'lazalong' on May 01, 2007, 10:55:14 pm
So much corrections... :shock:

Visiting Firenze must have been boring  :P
Title: Re: The 01 May 2007 build is out.
Post by: Grom on May 02, 2007, 12:43:43 am
wxSmith became really cool:wink:. We may see what can do one Slavic guy with keyboard.

But there is no wxGrid :cry:... As a result I made huge GUI to my project with wxFormBuilder and wxDevCpp.

I have no time to add wxGrid may self. Somobody!!! Please add wxGrid to the wxSmith. Only one piece in wxSmith is missing... :?
Title: Re: The 01 May 2007 build is out.
Post by: DBloke on May 02, 2007, 12:49:24 am
Somebody is on a roll with wxSmith, some serious fixes and enhancements
Excellent work Code::Blocks + wxSmith = exactly what C/C++ has been waiting for these past 20+ years :P
Title: Re: The 01 May 2007 build is out.
Post by: phireis on May 02, 2007, 03:37:49 am
The debugging windows still doestnt open for me too(it was reported at april 26th by danielking). None of them, this seems to have happened after changing to wxwidgets2.8. I'm on Windows XP, Gdb 6.3.
I'll go back to a debug working version (I miss watches so much). More people having this too?

Philipe
Title: Re: The 01 May 2007 build is out.
Post by: Biplab on May 02, 2007, 04:46:59 am
The debugging windows still doestnt open for me too(it was reported at april 26th by danielking). None of them, this seems to have happened after changing to wxwidgets2.8. I'm on Windows XP, Gdb 6.3.
I'll go back to a debug working version (I miss watches so much). More people having this too?

This is a wxWidgets related issue (I'm assuming you want to open various debugging related windows). AFAIK, there is a bug in wx2.8.3 which screws up pop-up menu. If you switch to wx2.8.4 (Currently in RC1), the issues goes away.

My suggestion to those who are facing this problem to use the Debug > Debugging windows > Watches to open up Watches window. When wx 2.8.4 will be used, this problem would go away.

Regards,

Biplab
Title: Re: The 01 May 2007 build is out.
Post by: killerbot on May 02, 2007, 07:27:29 am
So much corrections... :shock:

Visiting Firenze must have been boring  :P

not my credit, credit to the other programmers who committed these fixes. I just made a build out of it ;-)
Title: Re: The 01 May 2007 build is out.
Post by: red eagle on May 02, 2007, 11:07:18 am
This is my first post, congratulations on a wonderful piece of software.

Just a post to help Phireis, if you close the management sidebar window, and then reopen it, the debugging windows should work again.

Windows XP SP2


RED.
Title: Re: The 01 May 2007 build is out.
Post by: Rama on May 02, 2007, 11:30:56 am
The last couple builds I've used have had issues with cut and copy.

Cut: I cannot cut only a part of a line, and when I cut it also insists on cutting the the line immediately following what I wanted. This shows up both when cutting and pasting.

Copy: Same as above only with copy instead of cut.
Title: Re: The 01 May 2007 build is out.
Post by: Biplab on May 02, 2007, 11:39:45 am
The last couple builds I've used have had issues with cut and copy.

There are two solutions.
1. Disable cbKeybinder plugin.
2. Reassign the shortcuts.
Title: Re: The 01 May 2007 build is out.
Post by: Pecan on May 02, 2007, 02:31:39 pm
The last couple builds I've used have had issues with cut and copy.

Cut: I cannot cut only a part of a line, and when I cut it also insists on cutting the the line immediately following what I wanted. This shows up both when cutting and pasting.

Copy: Same as above only with copy instead of cut.

The menu structure has changed and the key definition ids nolonger match those memorized by KeyBinder. It'd be best if you'd delete cbKeyBinder10.ini from the CodeBlocks data folder and reenter your personal keys

Windows: c:\Documents and Settings\<user name>\Application Data\codeblocks\cbKeybinder...ini

*nix: ~/.codeblocks/cbkeybinder....ini.
Title: Re: The 01 May 2007 build is out.
Post by: Rama on May 02, 2007, 02:38:59 pm
Thank you very much, Pecan. I simply removed the file and all the (default I assume) key bindings are as I'm used to.
Title: Re: The 01 May 2007 build is out.
Post by: museeer on May 02, 2007, 03:05:22 pm
If you switch to wx2.8.4 (Currently in RC1), the issues goes away.
where I can find wx2.8.4?
Title: Re: The 01 May 2007 build is out.
Post by: wxLearner on May 02, 2007, 03:13:47 pm
where I can find wx2.8.4?
http://biolpc22.york.ac.uk/pub/ (http://biolpc22.york.ac.uk/pub/)
Title: Re: The 01 May 2007 build is out.
Post by: tufan on May 02, 2007, 03:26:34 pm
how can i make it indent after public,pri also ifs and fors without curly brackets and case: in a switch stament?if you can give the source of the latest release i can have a look at it too.i'm a developer.and this was for windows.
Title: Re: The 01 May 2007 build is out.
Post by: Ceniza on May 02, 2007, 03:35:48 pm
Sure, here (http://www.codeblocks.org/source_code.shtml)'s the source :wink:.
Title: Re: The 01 May 2007 build is out.
Post by: museeer on May 02, 2007, 03:48:59 pm
where I can find wx2.8.4?
http://biolpc22.york.ac.uk/pub/ (http://biolpc22.york.ac.uk/pub/)
thank you, but I have dial-up connection, exists wxmsw28u_gcc_cb_wx284.7z ~2MB?
Title: Re: The 01 May 2007 build is out.
Post by: stahta01 on May 02, 2007, 08:04:02 pm
@Killerbot

Can you give me some info on your build environment?

Your DLL is about 2 Megs smaller than mine is.

my wxmsw28u dll size is 10,349,134 bytes
yours wxmsw28u dll size is 8,090,112 bytes

My OS is XP(32 bit) SP2 

wxWidgets Build Command
mingw32-make -f makefile.gcc USE_XRC=1 SHARED=1 MONOLITHIC=1 BUILD=release UNICODE=1
Code: [Select]
what                file                line                                value
mingw-runtime       include/_mingw.h    #define __MINGW32_VERSION 3.10      3.10
Windows API         include/w32api.h    #define __W32API_VERSION 3.7        3.7

what                command                                                 value
GCC Version         gcc --version                                           gcc (GCC) 3.4.5 (mingw special)
binutils            ld --version                                            GNU ld version 2.17.50 20070129
Title: Re: The 01 May 2007 build is out.
Post by: killerbot on May 02, 2007, 08:51:06 pm
that's because the debug symbols have been stripped from it, due to update.bat
Title: Re: The 01 May 2007 build is out.
Post by: stahta01 on May 02, 2007, 09:15:21 pm
that's because the debug symbols have been stripped from it, due to update.bat

Thanks, that was the issue, note some reason update.bat was NOT stripping it for me.
(I place the DLLs in devel folder and the update.bat should strip it, after copying it to output folder but it was not for me.)
I did it manually and it much smaller.

Edit: Found cause, I reinstalled Cygwin a few weeks ago. I must have forgot to remove the path(s) from PATH Env. Var..
Note, I had to put strip.exe for minGW into a folder in the path for it to work.

Tim S
Title: Re: The 01 May 2007 build is out.
Post by: cstudent on May 03, 2007, 05:06:27 am
Is anyone else getting this error? (Ubuntu 7.04, wx2.6.3, gcc 4.1.2)

Code: [Select]
Manager initialized
Scanning for lexers in /usr/share/codeblocks/lexers/...
Found 27 lexers
Configured 0 tools
Scanning for plugins in /home/kirby/.codeblocks/share/codeblocks/plugins...
Found 0 plugins
Scanning for plugins in /usr/share/codeblocks/plugins...
ERROR: Plugin resource not found: libwxsmithlib.zip
Found 24 plugins
Loading: CodeSnippets Debugger ToDoList ScriptedWizard Compiler cbKeyBinder CodeStat HelpPlugin wxSmithContribItems CB_Koders Exporter SymTab AStylePlugin Profiler cbDragScroll CodeCompletion BYOGames lib_finder EnvVars ClassWizard Autosave wxSmith wxSmithMime FilesExtensionHandler RegExTestbed
Running startup script
Script/function 'edit_startup_script.script' registered under menu 'Settings/-Edit startup script'
Title: Re: The 01 May 2007 build is out.
Post by: MichaelW on May 03, 2007, 07:08:40 am
Hi,

I found a bug in the 1st May nightly build,
I use the Ubuntu 6xx package.

If you enter an program argument (with the menu Project -> Set Program' argument) and press run, the shell return :

Code: [Select]
sh: Syntax error: Unterminated quoted string

Press ENTER to continue.

It is because there is a quote at the end for the xterm command :

Code: [Select]
Checking for existence: /home/michael/Projects/OpenCvTest/bin/Debug/OpenCvTest
Executing: xterm -T 'OpenCvTest' -e'LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH /usr/bin/cb_console_runner "/home/michael/Projects/OpenCvTest/bin/Debug/OpenCvTest" Capture_00001.jpg' (in /home/michael/Projects/OpenCvTest/.)

I solved it by adding a quote at the end of my argument but it's a bit dirty.

By the way, i'm a big fan of code::blocks, and you do a great job.
Thanks

Michael
Title: Re: The 01 May 2007 build is out.
Post by: nottin on May 03, 2007, 08:15:37 am
Is anyone else getting this error? (Ubuntu 7.04, wx2.6.3, gcc 4.1.2)

Code: [Select]
Manager initialized
Scanning for lexers in /usr/share/codeblocks/lexers/...
Found 27 lexers
Configured 0 tools
Scanning for plugins in /home/kirby/.codeblocks/share/codeblocks/plugins...
Found 0 plugins
Scanning for plugins in /usr/share/codeblocks/plugins...
ERROR: Plugin resource not found: libwxsmithlib.zip
Found 24 plugins
Loading: CodeSnippets Debugger ToDoList ScriptedWizard Compiler cbKeyBinder CodeStat HelpPlugin wxSmithContribItems CB_Koders Exporter SymTab AStylePlugin Profiler cbDragScroll CodeCompletion BYOGames lib_finder EnvVars ClassWizard Autosave wxSmith wxSmithMime FilesExtensionHandler RegExTestbed
Running startup script
Script/function 'edit_startup_script.script' registered under menu 'Settings/-Edit startup script'

I'm seeing the same thing, plus one more error.
Code::Block svn 3917, wx2.8.4-rc1, gcc 4.1.2

Code: [Select]
Manager initialized
Scanning for lexers in /usr/local/share/codeblocks/lexers/...
Found 27 lexers
Configured 0 tools
Scanning for plugins in /home/bjorn/.codeblocks/share/codeblocks/plugins...
Found 0 plugins
Scanning for plugins in /usr/local/share/codeblocks/plugins...
ERROR: Plugin resource not found: libwxsmithlib.zip
ERROR: /usr/local/share/codeblocks/plugins/libwxsmithcontribitems.so: not loaded (missing symbols?)
Found 23 plugins
Loading: RegExTestbed CodeCompletion FilesExtensionHandler HelpPlugin ToDoList CodeStat ScriptedWizard Debugger CodeSnippets wxSmith wxSmithMime Compiler Autosave ClassWizard lib_finder cbDragScroll AStylePlugin SymTab cbKeyBinder BYOGames Profiler EnvVars Exporter CB_Koders
Running startup script
Script/function 'edit_startup_script.script' registered under menu 'Settings/-Edit startup script'