Code::Blocks

User forums => General (but related to Code::Blocks) => Topic started by: zhuxuan on March 30, 2007, 01:39:35 pm

Title: Can't save default layout and segment fault !
Post by: zhuxuan on March 30, 2007, 01:39:35 pm
My OS is Debian etch, wxWidgets is 2.6.3 ( Debian package ).

Everytime I run Code::Blocks, adjust the layout, then save it, it always does not work.
When I run Code::Blocks next time, all setting was gone !

I notice that there is a "default.conf" in user's application data directory (under windows), but I cannot find the "default.conf" in my ~/.codeblocks (under Debian).

So, what's wrong ? Any suggestion ?

BTW, when I run Code::Blocks, I get the "Gtk-CRITICAL **: gtk_window_realize_icon: assertion `info->icon_pixmap == NULL' failed" message, and the "Segment Fault" message when I close Code::Blocks.

Do I miss something ?

My Code::Blocks was build from svn, Code::Blocks Version revision 3798 (gcc 4.1.2).

Thanks a lot ! :)
Title: Re: Can't save default layout and segment fault !
Post by: GMG on April 01, 2007, 03:33:14 am
Are you referring to the layout of the editor?
Title: Re: Can't save default layout and segment fault !
Post by: zhuxuan on April 02, 2007, 06:46:00 am
Yes, the layout of Code::Blocks (tool bar, messages window ... and so on.)
Title: Re: Can't save default layout and segment fault !
Post by: TDragon on April 02, 2007, 01:41:12 pm
..., and the "Segment Fault" message when I close Code::Blocks.
The segfault happens before the C::B configuration can be saved; ergo, you lose your settings. I'm sure the developers would appreciate any further information you could get as to how it happens, such as a backtrace.