Code::Blocks

User forums => General (but related to Code::Blocks) => Topic started by: cprgmswr2 on May 11, 2006, 11:23:42 pm

Title: Restore default settings
Post by: cprgmswr2 on May 11, 2006, 11:23:42 pm
Is there a way to restore the default settings that come with codeblocks?
Title: Re: Restore default settings
Post by: thomas on May 11, 2006, 11:40:45 pm
If you use a recent build, then you can just delete the config file.
If you use the release candidate 2, you can seek Code::Blocks' key in the registry and delete that.
Title: Re: Restore default settings
Post by: cprgmswr2 on May 12, 2006, 01:17:23 am
I purpose that a new option be added within codeblocks to reset the settings back to the default installed settings
Title: Re: Restore default settings
Post by: sethjackson on May 12, 2006, 01:22:59 am
I purpose that a new option be added within codeblocks to reset the settings back to the default installed settings

You could do "codeblocks.exe --clear-configuration" (from the command line). That block of code inside app.cpp doesn't do anything besides pop-up a message box nowadays IIRC. So that isn't much help......
Title: Re: Restore default settings
Post by: takeshi miya on May 12, 2006, 02:38:45 am
I purpose that a new option be added within codeblocks to reset the settings back to the default installed settings

You could do "codeblocks.exe --clear-configuration" (from the command line). That block of code inside app.cpp doesn't do anything besides pop-up a message box nowadays IIRC. So that isn't much help......

Lol, that took me various days to discover that was the case. Reported here  (http://developer.berlios.de/bugs/?func=detailbug&bug_id=7001&group_id=5358)btw.
Title: Re: Restore default settings
Post by: sethjackson on May 12, 2006, 03:17:36 am
I purpose that a new option be added within codeblocks to reset the settings back to the default installed settings

You could do "codeblocks.exe --clear-configuration" (from the command line). That block of code inside app.cpp doesn't do anything besides pop-up a message box nowadays IIRC. So that isn't much help......

Lol, that took me various days to discover that was the case. Reported here  (http://developer.berlios.de/bugs/?func=detailbug&bug_id=7001&group_id=5358)btw.

Yea I had looked at that bug rpt to see if I could fix it.... Then I looked at the code.  :lol:
Title: Re: Restore default settings
Post by: thomas on May 12, 2006, 09:56:50 am
Problem solved.
Title: Re: Restore default settings
Post by: ProutDeMammouth on May 24, 2006, 08:39:58 am
Same chineese message about MP3 in four topics... may be some kind of ad?
Title: Re: Restore default settings
Post by: Defender on May 24, 2006, 08:57:16 am
This is spam, but we must not reply, unless we want to create more spam.
Title: Re: Restore default settings
Post by: mandrav on May 24, 2006, 09:39:04 am
Don't worry, these messages are pruned.
The only downside is that if they keep on coming, we 'll have to turn guest posting off...
Title: Re: Restore default settings
Post by: ProutDeMammouth on May 24, 2006, 09:51:08 am
Don't worry, these messages are pruned.
You are right:
This bug will be fixed soon...
... with a patch? :wink:
Title: Re: Restore default settings
Post by: mandrav on May 24, 2006, 09:57:45 am
This bug will be fixed soon...
... with a patch? :wink:

No, with other measures. The spammer's IP has been banned and a complaint email has been sent to his ISP.
:)