Code::Blocks

User forums => General (but related to Code::Blocks) => Topic started by: CBuser5962 on June 11, 2020, 10:24:50 am

Title: CB 20.03 : error ld.exe libxxxx.a not found !
Post by: CBuser5962 on June 11, 2020, 10:24:50 am
Hi,

I used CB 17.12 with some libraries (libxxxx.a such that libconio.a or libmeschach.a). Include and lib directories were specified through the Compiler options (search directories). There was no problem about the compilation and the link edition...

I've desinstalled CB 17.12 to install new version of CB 20.03.

First I tried the 64-bit version of MingW included in codeblocks-20.03mingw-setup.exe. Problem with compilation of C programs : error ld.exe libxxxx.a not found !

I've desinstalled this version to install the 32-bit version included in codeblocks-20.03mingw-32bit-setup.exe. The same error appears in the compilation of C programs ! In the both cases, search directories were correctly set !

Can anybody help me please ?
Title: Re: CB 20.03 : error ld.exe libxxxx.a not found !
Post by: stahta01 on June 11, 2020, 12:57:16 pm
Figure out what compiler you were using and change CB to use that Compiler!

Stop installing CB with Compiler and install CB and Compiler separately.
Do not install Compiler under CB.

Tim S.


Title: Re: CB 20.03 : error ld.exe libxxxx.a not found !
Post by: CBuser5962 on June 13, 2020, 04:04:48 pm
I've installed CodeBlocks 20.03 (64-bit version, standalone) and MinGW C/C++ compiler separately. Now it works fine ! Thanks for your advice Tim ! ;-)