Code::Blocks

User forums => Help => Topic started by: Avan on December 25, 2019, 12:18:44 pm

Title: Cannot build Code::Blocks
Post by: Avan on December 25, 2019, 12:18:44 pm
Hello?

I'm a newcomer to C::B and cannot seem to get the Dec 15 Nightly to compile the C::B sources.
 
I've got:
- Code::Blocks 11927 Nightly
- Code::Blocks SVN Latest Sources
- MinGW64 8.x.x
- wxWidgets 3.1.3

I've rebuild wsWidgets 3.1.3 succesfully to the same dll-sizes as the ones from the forum and the Nightly runs with those (even generates the same errors).

But there its ends. The compiler spits out blue warnings and red errors when I try to rebiuld the C::B code. It gets to Squirrel (57%) before the first warning appears and Build Messages show a lot of "redefined" stuff. The first error is:
D:\CodeBlocks-head\src\sdk\wxpropgrid\src\propgrid.cpp|9636|error: macro "WX_PG_IMPLEMENT_VARIANT_DATA" passed 2 arguments, but takes just 1|

Anyone have a clue of what is going on here?
Title: Re: Cannot build Code::Blocks
Post by: stahta01 on December 25, 2019, 12:25:46 pm
You are likely trying to build the wrong CB Project or Workspace.

Try building "CodeBlocks_wx31.cbp" and see if that builds.
Edit: You likely want "CodeBlocks_wx31_64.cbp" for 64 bit, I forgot that.

If not, post the "build log"!

Tim S.


Title: Re: Cannot build Code::Blocks
Post by: Avan on December 25, 2019, 12:57:55 pm
Tim,

Thanks, that (and 64bit) did the trick! Until now I even had no clue is I was doing 64 bit as the compiler name has 32 in it...

Can I run this exe in the dev-folder and should it work like the 'real' one. Or do I the dev copies over to the 'real' instance?
Title: Re: Cannot build Code::Blocks
Post by: Avan on December 25, 2019, 02:20:13 pm
Got it Tim, Just found the wiki:

http://wiki.codeblocks.org/index.php/Installing_Code::Blocks_from_source_on_Windows#Build_wxWidgets_Support_Library