Code::Blocks

Developer forums (C::B DEVELOPMENT STRICTLY!) => Development => Topic started by: Rahul on December 19, 2019, 01:00:24 am

Title: unknown type name ‘scm_t_wchar
Post by: Rahul on December 19, 2019, 01:00:24 am
asked in codeblocks:-
---------------------

hi to all, I've centos 7.5 in VM. And i am trying to compile graphics program in C::B. I installed libgraph successfully and trying to build following program :-
Code: [Select]

//#include <graphics.h>
// graphics in linux enviornment
#include<cstdio>
#include<cstdlib>
#include<graphics.h>

//using namespace std;
int main()
{
    int gd = DETECT, gm;
    initgraph(&gd, &gm, NULL);

    circle(50, 50, 30);

    delay(5000);
    closegraph();
    return 0;
}
it gives following o/p :-
Code: [Select]
||=== Build: Debug in graphics in c (compiler: GNU GCC Compiler) ===|
/usr/include/libguile/strings.h|151|error: unknown type name ‘scm_t_wchar’|
/usr/include/libguile/strings.h|152|error: unknown type name ‘scm_t_wchar’|
/usr/include/libguile/strings.h|153|error: unknown type name ‘scm_t_wchar’|
/usr/include/libguile/strings.h|154|error: unknown type name ‘scm_t_wchar’|
/usr/include/libguile/strings.h|182|error: unknown type name ‘scm_t_wchar’|
/usr/include/libguile/strings.h|192|error: unknown type name ‘scm_t_wchar’|
/usr/include/libguile/strings.h|198|error: unknown type name ‘scm_t_wchar’|
/usr/include/libguile/strings.h|201|error: unknown type name ‘scm_t_wchar’|
/usr/include/libguile/strings.h|210|error: unknown type name ‘scm_t_wchar’|
/usr/include/libguile/strings.h|215|error: unknown type name ‘scm_t_wchar’|
||=== Build failed: 10 error(s), 0 warning(s) (0 minute(s), 0 second(s)) ===|
how to recover this.
Title: Re: unknown type name ‘scm_t_wchar
Post by: stahta01 on December 19, 2019, 01:07:19 am
Post a full build log!
Title: Re: unknown type name ‘scm_t_wchar
Post by: stahta01 on December 19, 2019, 01:10:55 am
Quote
I installed libgraph successfully

What does that mean in detail!!!

Tim S.
Title: Re: unknown type name ‘scm_t_wchar
Post by: Rahul on December 19, 2019, 01:34:10 am
I installed "libgraph-1.0.2.tar.gz" with all of its dependencies.

sorry guys i attached "/usr/include/ligguile "  and after removing that from search directories. It ran but now having two errors:-
in terminal
Code: [Select]
[[email protected] Debug]# ./grph
The font has not been loaded!
[[email protected] Debug]#

and in IDE :-
Code: [Select]
[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, aorry aboput that.
grph: xcb_io.c:263: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed
Title: Re: unknown type name ‘scm_t_wchar
Post by: stahta01 on December 19, 2019, 01:37:48 am
POST A FULL BUILD LOG!

Edit: Since, it now builds no log really needed; but, it is no longer a CB Problem.

http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_%28general%29#Q:_How_do_I_report_a_compilation_problem_on_the_forums.3F (http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_%28general%29#Q:_How_do_I_report_a_compilation_problem_on_the_forums.3F)
Title: Re: unknown type name ‘scm_t_wchar
Post by: stahta01 on December 19, 2019, 01:41:51 am
I suggest getting rid of 15 year old "libgraph-1.0.2.tar.gz".

You might try reading this website rules.
http://forums.codeblocks.org/index.php/topic,9996.0.html (http://forums.codeblocks.org/index.php/topic,9996.0.html)

You might try SDL BGI instead.
https://sourceforge.net/projects/libxbgi/files/ (https://sourceforge.net/projects/libxbgi/files/)

Tim S.