Code::Blocks

User forums => Help => Topic started by: marcusbarnet on October 01, 2019, 12:02:59 pm

Title: How to install WxSmith on codeblocks 17
Post by: marcusbarnet on October 01, 2019, 12:02:59 pm
Hi to all,

I updated Codeblocks from version 16.01 to 17.12 and I realized that the Wxsmith plugin is not loaded anymore.
Unfortunately, I have several projects based on WxSmith and so I need to load this plugin.

I tried to install it by using apt-get:

Code: [Select]
sudo apt-get install libwxsmithlib0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libwxsmithlib0 is already the newest version (17.12-1).
0 upgraded, 0 newly installed, 0 to remove and 149 not upgraded.

and

Code: [Select]
sudo apt-get install codeblocks-contrib
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 codeblocks-contrib : Depends: codeblocks (= 16.01+dfsg-2.1) but 17.12-1 is to be installed
                      Depends: libwxsmithlib0 (= 16.01+dfsg-2.1) but 17.12-1 is to be installed
                      Recommends: valgrind but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

How can I solve the problem?
Title: Re: How to install WxSmith on codeblocks 17
Post by: oBFusCATed on October 01, 2019, 02:03:25 pm
Remove all old packages and then install the new ones. If you're installing manually make sure to pass all .deb files to the command line, so it could resolve dependencies...
Title: Re: How to install WxSmith on codeblocks 17
Post by: marcusbarnet on October 01, 2019, 03:15:09 pm
I solved by manually installing old dependences needed by codeblocks_contrib.
These dependences can't be installed by using apt-get because they are too old for the recent Ubuntu OS.