Code::Blocks

User forums => Nightly builds => Topic started by: killerbot on February 13, 2006, 11:35:54 pm

Title: The 13 february 2006 build is out.
Post by: killerbot on February 13, 2006, 11:35:54 pm
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml
A link to the unicode windows wxWidget dll for Code::Blocks : http://download.berlios.de/codeblocks/wxmsw26u_gcc_cb.7z
For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://download.berlios.de/codeblocks/mingwm10.7z

For support of ansi builds, a link to the ansi windows wxWidget dll for Code::Blocks : http://download.berlios.de/codeblocks/wxmsw26_gcc_cb.7z

The 13 February 2006 build is out.
  - Windows : http://download.berlios.de/codeblocks/CB_20060213_rev2001_win32.7z
  - Linux : not supported yet


Resolved Fixed:


Regressions/Confirmed/Annoying/Common bugs:


Title: Re: The 13 february 2006 build is out.
Post by: Acki on February 14, 2006, 02:51:36 am
Hi,
I think there is a little bug now...
I can't delete tools from the tools menu anymore !!!
Title: Re: The 13 february 2006 build is out.
Post by: tiwag on February 14, 2006, 08:28:40 am
custom variables can't be deleted either ...
Title: Re: The 13 february 2006 build is out.
Post by: Szabadember on February 14, 2006, 11:31:50 am
Quote
DDE bug : clicking in windows explorer on a CB registered file throws an error message box

This bug is not present anymore for me!(for about i don't know how much builds now)
Title: Re: The 13 february 2006 build is out.
Post by: killerbot on February 14, 2006, 11:41:53 am
it seems to be gone, but I had it happening on me, last week (once).
Title: Re: The 13 february 2006 build is out.
Post by: artur on February 14, 2006, 12:35:21 pm
When I use Polish characters in source code
       wxMessageBox(_("Błąd podczas pobierania listy baz"), _("BŁĄD"), wxICON_ERROR | wxOK);
CB writes on HDD empty file.
When I delete these characters file is written OK.
Title: Re: The 13 february 2006 build is out.
Post by: tiwag on February 14, 2006, 12:45:17 pm
When I use Polish characters in source code
       wxMessageBox(_("Błąd podczas pobierania listy baz"), _("BŁĄD"), wxICON_ERROR | wxOK);
CB writes on HDD empty file.
When I delete these characters file is written OK.

use UTF-8 encoding

Edit->File Encoding->
Title: Re: The 13 february 2006 build is out.
Post by: killerbot on February 14, 2006, 03:24:59 pm
Quote
I can't delete tools from the tools menu anymore !!!

Quote
custom variables can't be deleted either ...

Yiannis has fixed those in rev 2002
Title: Re: The 13 february 2006 build is out.
Post by: Szabadember on February 14, 2006, 04:05:34 pm
When will be Code::Blocks RC3 out?
Are there any more serious bugs, that need to be fixed?
Title: Re: The 13 february 2006 build is out.
Post by: thomas on February 14, 2006, 04:42:26 pm
When will be Code::Blocks RC3 out?
When it's ready.  (Trademark owned by mandrav).

Are there any more serious bugs, that need to be fixed?
Yes, several bugs as well as a few things that are still rather suboptimal.
Title: Re: The 13 february 2006 build is out.
Post by: Acki on February 14, 2006, 08:15:50 pm
custom variables can't be deleted either ...

But I could before this version !!!
I recopied the old version, deleted the tools and copie the new version again over it !!!
But if I trie this with the new version I can't !?!?!
I go to the customize tools menu, select a tool, click on "remove", I get asked if I really whant to, I select yes but the entry is still there !!!!!
Title: Re: The 13 february 2006 build is out.
Post by: killerbot on February 14, 2006, 08:18:25 pm
This was a bug introduced yesterday, tonight nightly (which is building at this very moment) will have it fixed :-)
Title: Re: The 13 february 2006 build is out.
Post by: Zingam on February 14, 2006, 09:23:40 pm
When I use Polish characters in source code
       wxMessageBox(_("Błąd podczas pobierania listy baz"), _("BŁĄD"), wxICON_ERROR | wxOK);
CB writes on HDD empty file.
When I delete these characters file is written OK.

use UTF-8 encoding

Edit->File Encoding->

Something doesn't work here. First before I chose UTF-8 an empty file was saved overwritting everyting. After that I've chosen UTF-8 but after saving CB the characters were not the right one. I was trying to use cyrillic characters.

Is it possible for CB to automatically detect the encoding, when using non-ASCII characters?

Should I report this as a bug or as suggestion for a new feature?
Title: Re: The 13 february 2006 build is out.
Post by: tiwag on February 14, 2006, 10:00:32 pm
When I use Polish characters in source code
       wxMessageBox(_("Błąd podczas pobierania listy baz"), _("BŁĄD"), wxICON_ERROR | wxOK);
CB writes on HDD empty file.
When I delete these characters file is written OK.

use UTF-8 encoding

Edit->File Encoding->

Something doesn't work here. First before I chose UTF-8 an empty file was saved overwritting everyting. After that I've chosen UTF-8 but after saving CB the characters were not the right one. I was trying to use cyrillic characters.

Is it possible for CB to automatically detect the encoding, when using non-ASCII characters?

Should I report this as a bug or as suggestion for a new feature?

i also had 0-byte files when saving as ISO-encoded file, but it worked for me after switching to UTF-8, but i don't use cyrillic chars  :roll:
Title: Re: The 13 february 2006 build is out.
Post by: Game_Ender on February 14, 2006, 10:51:10 pm
Yes, several bugs as well as a few things that are still rather suboptimal.

Is there any time to setup a roadmap kind of like what Ogre (http://www.ogre3d.org/wiki/index.php/DagonNotes#Annotated_roadmap) has.  I am sure you or Mandrav, already has one in there head, this just gives the community a little more insight into the fast developement cycle codeblocks has.
Title: Re: The 13 february 2006 build is out.
Post by: artur on February 15, 2006, 07:38:47 am
When I use Polish characters in source code
       wxMessageBox(_("Błąd podczas pobierania listy baz"), _("BŁĄD"), wxICON_ERROR | wxOK);
CB writes on HDD empty file.
When I delete these characters file is written OK.

use UTF-8 encoding

Edit->File Encoding->

Something doesn't work here. First before I chose UTF-8 an empty file was saved overwritting everyting. After that I've chosen UTF-8 but after saving CB the characters were not the right one. I was trying to use cyrillic characters.

Is it possible for CB to automatically detect the encoding, when using non-ASCII characters?

Should I report this as a bug or as suggestion for a new feature?

i also had 0-byte files when saving as ISO-encoded file, but it worked for me after switching to UTF-8, but i don't use cyrillic chars  :roll:

I've switched encoding to UTF-8 and then files were seved correctly, but...
When I've closed file and reopened it (without closing CB) encoding was set to ASCII again.
Title: Re: The 13 february 2006 build is out.
Post by: mandrav on February 15, 2006, 08:35:39 am
If you 're having problems, please start a new topic. This forum is only for nightlies announcements.

C::B doesn't perform encoding detection (yet). If someone wants to implement it, patches are welcome.
Here's a link to help you get started: A composite approach to language/encoding detection (http://www.mozilla.org/projects/intl/UniversalCharsetDetection.html)
Title: Re: The 13 february 2006 build is out.
Post by: takeshi miya on February 15, 2006, 09:14:58 am
If you saved as UTF-8, just make sure to save it with the BOM.
Title: Re: The 13 february 2006 build is out.
Post by: Antrykot on February 15, 2006, 09:56:57 am
Hi,
When I remove some files from project (about 3 or 4) the CB crashes (on Windows XP) :/
Can you fix this ? :)
Title: Re: The 13 february 2006 build is out.
Post by: Michael on February 15, 2006, 11:40:22 am
Is there any time to setup a roadmap kind of like what Ogre (http://www.ogre3d.org/wiki/index.php/DagonNotes#Annotated_roadmap) has.

Ogre annotated roadmap looks good, clear and easy to read.

Michael