Code::Blocks

User forums => Help => Topic started by: PaulKBSR on October 16, 2018, 05:13:36 pm

Title: Can't install on Mint 19 due to "libcodeblocks0(=17.12.1) dependency issue.
Post by: PaulKBSR on October 16, 2018, 05:13:36 pm
Hi,

I downloaded the package for Debian amd64 stable and unpacked into it's own directory.  I attempted to install "codeblocks_17.12-1_amd64.deb" and received the following error in the Package Installer:  Dependency not satisfiable: libcodeblocks0(=17.12.1)

Can you please assist me in getting it installed.  I could install it from the repository but I want the latest release.

Thanks!
Title: Re: Can't install on Mint 19 due to "libcodeblocks0(=17.12.1) dependency issue.
Post by: oBFusCATed on October 16, 2018, 08:05:08 pm
You have to install most deb files with a single command. Something like dpkg blabla *.deb. I don't use debian, so I don't know the exact details.
Title: Re: Can't install on Mint 19 due to "libcodeblocks0(=17.12.1) dependency issue.
Post by: PaulKBSR on October 17, 2018, 04:25:16 am
After some creative installation all is well.  Thanks for the push in the right direction!