Code::Blocks

User forums => Help => Topic started by: evolutional on April 10, 2005, 12:20:14 pm

Title: Debugger path problems
Post by: evolutional on April 10, 2005, 12:20:14 pm
My current project is separated like this:

/
--(output & data files)
--/src
----(.cpp files)
----(CBP project)
--/include
----(.h files)

Some of my header files contain inline code that I need to debug, however when invoking GDB I get the error from the debugger:

Starting debugger: done
No source file named ..\\include\\game_interpanimator.h.
error

Basically, it seems like I can't debug any files not inside the directory that my CBP file is located. Can someone give me any tips on how to rectify this?
Title: Debugger path problems
Post by: mandrav on April 10, 2005, 01:31:36 pm
This has been fixed in CVS. The upcoming release (expected this week) has many improvements/bug-fixes, including this :)

Yiannis.
Title: Debugger path problems
Post by: Anonymous on April 13, 2005, 04:11:42 pm
Brilliant. You're doing some excellent work Yiannis.

-evolutional
Title: Debugger path problems
Post by: developer on May 07, 2005, 05:33:24 am
Not doubt a great work.
But I'm using the Code::Blocks version 1.0-beta7 and it still has this (or a similar) problem.
I have my project seperated exactly in the same style /src /include and when I set a breakpoint in one of those files it gives me that same msg  but with the / slahes (Win32)
The only way to debug is to remove all files from the project and add them again in the "main" dir. :S
Any help?
Thanks
Title: Debugger path problems
Post by: EricBurnett on May 08, 2005, 08:51:09 pm
There are two issues that this could be. One is the path problem...I will be putting out a patch for that today (if it passes inspection!). The other is the question of what target it is in. For instance, you will get that message if you try to debug compilergcc.cpp, but chose the main codeblocks target (src). Since that target does not include the file, it will not be found.
Title: Debugger path problems
Post by: Anonymous on May 10, 2005, 04:35:17 am
Guess it didn't pass inspection?
Title: Debugger path problems
Post by: Anonymous on May 10, 2005, 07:09:13 am
I've got the debugger working for me now by closing code::blocks, doing a search-and-replace to change src\ to src/ in my .cbp file, and then by not using 'run to cursor' (breakpoints seem to work now, but run to cursor doesn't).
Title: Debugger path problems
Post by: mandrav on May 10, 2005, 08:04:26 am
Quote from: Anonymous
Guess it didn't pass inspection?

And what makes you say that? Eric's patch (along with some other improvements) was applied in CVS yesterday :)

Yiannis.