Code::Blocks

User forums => Help => Topic started by: Mungo1981 on July 29, 2018, 03:06:59 pm

Title: Help to install Code::Blocks on Linux Mint
Post by: Mungo1981 on July 29, 2018, 03:06:59 pm
Dear Community,
I have seen that it would give a Simple Install Webpage to install this IDE on Linux Mint.
And so I would have install it.
But when I would "build and run" a simple "Hello World" Programm, which would run through GCC, it would not work.
So my problem is: How can I fix this Problem
 >:(  :-[ :'(
Title: Re: Help to install Code::Blocks on Linux Mint
Post by: stahta01 on July 29, 2018, 06:24:20 pm
http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_%28general%29#Q:_How_do_I_report_a_compilation_problem_on_the_forums.3F (http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_%28general%29#Q:_How_do_I_report_a_compilation_problem_on_the_forums.3F)

Post a Build log
Title: Re: Help to install Code::Blocks on Linux Mint
Post by: Mungo1981 on July 29, 2018, 07:23:54 pm
Execuse me,
but I have tried to use a C Code "Hello World" from http://www.c-howto.de/tutorial/einfuehrung/hello-world/
And it will compile and link with gcc.
Also I have set default compiller and Project Compiler to gcc.
And It wouldn't compile
The Error is:

-------------- Run: Debug in Tast (compiler: GNU GCC Compiler)---------------

Checking for existence: /home/oem/MeinTestC/Tast/bin/Debug/Tast
Executing: xterm -T Tast -e /usr/bin/cb_console_runner LD_LIBRARY_PATH=$LD_LIBRARY_PATH:. /home/oem/MeinTestC/Tast/bin/Debug/Tast  (in /home/oem/MeinTestC/Tast/.)
Process terminated with status -1 (0 minute(s), 0 second(s))
 
Title: Re: Help to install Code::Blocks on Linux Mint
Post by: Mungo1981 on July 29, 2018, 07:46:05 pm
VERRY ESCUSE ME::
I have to install xterm as first.
I'm a litle bit stupid but I have think that in a Installation Script - presentet on a Linux Mint Homepage - this dependencie would solved automaticly.
So I have install xterm, and new all will work perfect-

 :D >:( :( :o ??? :-\
Title: Re: Help to install Code::Blocks on Linux Mint
Post by: oBFusCATed on July 29, 2018, 08:24:58 pm
If you don't like xterm you could select another terminal in the settings -> environment -> general