Code::Blocks

User forums => Nightly builds => Topic started by: jmccay on February 07, 2006, 03:18:48 am

Title: Revision 1594
Post by: jmccay on February 07, 2006, 03:18:48 am
  I just compiled revision 1594 with Unicode, and when I started it up, I got the following error message:

"Can't open registry key 'HKCU\Software\Classes\.d' (error 2: the system cannot find the file specified.)"

I thought the that codeblocks no longer used the registry?  This has only happened the first time (so far) that I loaded up the new project after compiling it today (2/6/2006).

Also, should I be putting these under another directory?

jmccay
Title: Re: Revision 1594
Post by: tiwag on February 07, 2006, 06:21:32 am
we're already in 1954 ;-)
Title: Re: Revision 1594
Post by: killerbot on February 07, 2006, 07:37:10 am
I am aware of that problem, no idea why it happens, I had it once with a .cbp also. Indeed it shows up once, and then it is gone, and the key in the registry is created. Weird. Registry is used to register file types of CB, nothing more.
Title: Re: Revision 1594
Post by: thomas on February 07, 2006, 08:34:04 am
That is apparently a wxWidgets bug.
This happens ever since Lieven's registry patch for Windows 98 compatibility was applied. However, Lieven's code seems to be perfectly correct, it first checks whether a key exists, and if it does not, the key is created. At that point, an error that the key cannot be opened is generated, which is outright silly (of course it does not exist, that's why we create it).