Code::Blocks

Developer forums (C::B DEVELOPMENT STRICTLY!) => Contributions to C::B => Topic started by: gd_on on March 28, 2018, 11:16:16 am

Title: Compile problem with FortranProject and C::B SVN 11352
Post by: gd_on on March 28, 2018, 11:16:16 am
I tried to compile C::B svn 11352 but there is a problem when compiling FortranProject :

Code: [Select]
||=== Générer : default dans FortranProject (compilateur : GNU GCC Compiler) ===|
C:\Users\Gerard\Documents\CodeBlocks_SVN\CodeBlocks_src\src\plugins\contrib\FortranProject\finfowindow.cpp||In constructor 'FInfoWindow::FInfoWindow()':|
C:\Users\Gerard\Documents\CodeBlocks_SVN\CodeBlocks_src\src\plugins\contrib\FortranProject\finfowindow.cpp|31|error: no matching function for call to 'EditorColourSet::Apply(HighlightLanguage, cbStyledTextCtrl*&)'|
C:\Users\Gerard\Documents\CodeBlocks_SVN\CodeBlocks_src\src\plugins\contrib\FortranProject\finfowindow.cpp|31|note: candidates are:|
..\..\..\include\editorcolourset.h|111|note: HighlightLanguage EditorColourSet::Apply(cbEditor*, HighlightLanguage, bool)|
..\..\..\include\editorcolourset.h|111|note:   candidate expects 3 arguments, 2 provided|
..\..\..\include\editorcolourset.h|112|note: void EditorColourSet::Apply(HighlightLanguage, cbStyledTextCtrl*, bool, bool)|
..\..\..\include\editorcolourset.h|112|note:   candidate expects 4 arguments, 2 provided|
||=== Génération de terminé : 1 erreur(s), 0 avertissement(s) (0 minute(s), 2 seconde(s)) ===|

My previous svn 11345 build was OK.

gd_on
Title: Re: Compile problem with FortranProject and C::B SVN 11352
Post by: oBFusCATed on March 28, 2018, 06:53:43 pm
There is a change in the API, the plugin must be adjusted for this to work.
Title: Re: Compile problem with FortranProject and C::B SVN 11352
Post by: crobar on August 17, 2018, 12:57:20 pm
I have the same problem with the python plugin, could you give a tip on what the fix might be in the 17.02 release?
Title: Re: Compile problem with FortranProject and C::B SVN 11352
Post by: Miguel Gimenez on August 17, 2018, 01:14:23 pm
It was fixed adding a new parameter (true) to the function call. If this doesn't solve your issue please post the build log mesages and source versions.