Code::Blocks

User forums => Help => Topic started by: HurgleGurgle on March 11, 2018, 02:25:27 am

Title: Assertation failure when trying to compile
Post by: HurgleGurgle on March 11, 2018, 02:25:27 am
I've been trying to get CodeBlocks 17.12-1 to work on Linux Mint. So far, I can open the program and write code in it, but when I save the file and try to build it, I get this error:

./src/common/strconv.cpp(3018): assert "Assert failure" failed in wxCSConv(): invalid encoding value in wxCSConv ctor

Can anyone tell me what this means and how to fix it?
Title: Re: Assertation failure when trying to compile
Post by: oBFusCATed on March 11, 2018, 12:06:02 pm
What is the encoding for the file you're using?
Are you sure you have typed characters correctly for this enconding in the whole file?

What happens if you click the continue button in the wxAssert dialog?

I guess you're hitting this problem: https://sourceforge.net/p/codeblocks/tickets/305/
Title: Re: Assertation failure when trying to compile
Post by: HurgleGurgle on March 11, 2018, 10:52:07 pm
I'm using UTF-8. I'm not quite sure what you mean by the second question. When I click the continue button, the document does save, but it doesn't compile. It's only a simple "Hello world" program, so there's nothing wrong with the code.
Title: Re: Assertation failure when trying to compile
Post by: stahta01 on March 12, 2018, 01:58:11 am
I'm using UTF-8. I'm not quite sure what you mean by the second question. When I click the continue button, the document does save, but it doesn't compile. It's only a simple "Hello world" program, so there's nothing wrong with the code.

Post the full build log!

Edit: Add post the editor encoding settings