Code::Blocks

User forums => Using Code::Blocks => Topic started by: simonchang on January 30, 2018, 06:06:29 am

Title: pgf90-Error-Unknown switch: -Wall
Post by: simonchang on January 30, 2018, 06:06:29 am
Debug in tem3dfdtd (compiler: PGI Fortran ACC)---------------

pgf90.exe -Wall  -g  -acc -Minfo -Mcuda=cuda8.0 -Minline,reshape    -c F:\WorkSpace\tem3d\tem3dfdtd\lib\allocatememory.f90 -o obj\Debug\lib\allocatememory.o
pgf90-Error-Unknown switch: -Wall
Process terminated with status 1 (0 minute(s), 0 second(s))
0 error(s), 0 warning(s) (0 minute(s), 0 second(s))

None of the programs (even very simple ones) can be debugged
 
Title: Re: pgf90-Error-Unknown switch: -Wall
Post by: stahta01 on January 30, 2018, 06:19:00 am
Remove the option not supported by your toolchain.

Remember to look in the compiler other/extra setting area.

Tim S.
Title: Re: pgf90-Error-Unknown switch: -Wall
Post by: simonchang on January 30, 2018, 06:40:41 am
Remove the option not supported by your toolchain.

Remember to look in the compiler other/extra setting area.

Tim S.

Sorry, I have already tried this. And -wall always appears, and if i select it, there will be two -Wall s in the command lime.
Title: Re: pgf90-Error-Unknown switch: -Wall
Post by: BlueHazzard on January 30, 2018, 12:09:09 pm
Possible locations for this flag:
1) Global compiler settings: Settings->Compiler->Select the fortran compiler from the drop down menu on the topl->Compiler settings->Compiler flags
2) Global compiler settings: Settings->Compiler->Select the fortran compiler from the drop down menu on the top->Compiler settings->Other compiler options
3) Global project settings:   Project->Build options->Select the project name on the left tree control->Compiler settings->Compiler flags
4) Global project settings:   Project->Build options->Select the project name on the left tree control->Compiler settings->Other compiler options
5) Build Target settingss:   Project->Build options->Select the target name on the left tree control->Compiler settings->Compiler flags
6) Build Target settings:   Project->Build options->Select the target name on the left tree control->Compiler settings->Other compiler options

How is the command line generated:
1) Global compiler settings + Project compiler settings + Target compiler settings

If you still get the error: http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_(general)#Q:_How_do_I_report_a_compilation_problem_on_the_forums.3F
And probably post the project file too
Title: Re: pgf90-Error-Unknown switch: -Wall
Post by: simonchang on January 30, 2018, 05:12:54 pm
Possible locations for this flag:
1) Global compiler settings: Settings->Compiler->Select the fortran compiler from the drop down menu on the topl->Compiler settings->Compiler flags
2) Global compiler settings: Settings->Compiler->Select the fortran compiler from the drop down menu on the top->Compiler settings->Other compiler options
3) Global project settings:   Project->Build options->Select the project name on the left tree control->Compiler settings->Compiler flags
4) Global project settings:   Project->Build options->Select the project name on the left tree control->Compiler settings->Other compiler options
5) Build Target settingss:   Project->Build options->Select the target name on the left tree control->Compiler settings->Compiler flags
6) Build Target settings:   Project->Build options->Select the target name on the left tree control->Compiler settings->Other compiler options

How is the command line generated:
1) Global compiler settings + Project compiler settings + Target compiler settings

If you still get the error: http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_(general)#Q:_How_do_I_report_a_compilation_problem_on_the_forums.3F
And probably post the project file too

Problem solved!
Thank you~