Code::Blocks

User forums => Help => Topic started by: Apelaths on January 10, 2018, 09:41:28 am

Title: Greek In Code::Blocks 17.12
Post by: Apelaths on January 10, 2018, 09:41:28 am
Hello

I used Code:Blocks 16.01 to program console applications(in C language), I added these -finput-charset=cp1253, -fexec-charset=cp737 to print Greek and everything was OK. I do the same in 17.12 but I could not print, actually I saw characters but is not Greek. Can someone help me?

Thank you very much!
Title: Re: Greek In Code::Blocks 17.12
Post by: BlueHazzard on January 11, 2018, 09:13:38 pm
I would use UTF-8 (specially if you are only using printf):

http://forums.codeblocks.org/index.php/topic,18803.msg128791.html#msg128791

EDIT: If you need more help please tell us your compiler and operating system
EDIT2: Where do you see no characters

EDIT3: A even better description: http://forums.codeblocks.org/index.php/topic,22168.msg150872.html#msg150872
Title: Re: Greek In Code::Blocks 17.12
Post by: Apelaths on January 18, 2018, 08:38:27 am
Thank you very much BlueHazzard for your reply. I tried everything you said but the problem still remains. I uninstalled the 17.12 version and I installed the 16.01 which I had no problem as a described at my first post. I did everything I said but I have the same problem. My operating system is windows 10 (with the last update) and my compiler is GNU GCC. I see characters but are gibberish as you described  to the link in EDIT3.   
Title: Re: Greek In Code::Blocks 17.12
Post by: oBFusCATed on January 18, 2018, 09:37:23 am
I don't think anything related to this has changed in 17.12.
Are you using the same compiler as in 16.01?
Have you inspected the build log to verify that the options have been passed to the compiler?
Title: Re: Greek In Code::Blocks 17.12
Post by: Apelaths on January 18, 2018, 01:00:50 pm
Yes I use the same compiler. Yes I have checked them, everything is ok... Is there any possibility the last windows update create the problem?
Title: Re: Greek In Code::Blocks 17.12
Post by: BlueHazzard on January 18, 2018, 04:10:02 pm
Some minimal example project?
Some full build log? http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_(general)#Q:_How_do_I_report_a_compilation_problem_on_the_forums.3F
On my approach:
1) Did you made sure you use the right font?
2) Did you made sure you removed all your compiler flags?
3) Did you made sure all your files where utf8 encoded? (post a example file)
4) Did you made sure that the console uses the right encoding?
5) Are you sure you recompiled everything (not just build, but clean + build, or rebuild)

4) Was this problem also prior to windows 10, or did it begin with windows 10?

5) My approach works for a lot people so i thing you have to check all your settings and steps again.
6) Describe exactly the steps you do to us. Describe them on the fly you do them so you have a check list and be sure you made all steps and we can correct them....

On your approach i can not help you...