Code::Blocks

User forums => General (but related to Code::Blocks) => Topic started by: awake on January 05, 2018, 11:48:00 pm

Title: Compiling 17.12 on Linux - best to use wx 2.8? 3.0? or 3.1?
Post by: awake on January 05, 2018, 11:48:00 pm
As the subject line says - is there a preference for which version of wxWidgets to use? I just successfully compiled against 2.8.12, and thus far it seems to be working fine (but need more testing to be sure) - is there any advantage to compiling vs. 3.0 or 3.1?
Title: Re: Compiling 17.12 on Linux - best to use wx 2.8? 3.0? or 3.1?
Post by: stahta01 on January 06, 2018, 12:06:32 am
Normally you compile against whatever wxWidgets version is packaged by the Linux OS.

On Windows, there are known wxWidgets 3.0 bugs in Code::Blocks.
On Linux, normally wxWidgets 3.0 is used; so, it is easier to confirm issues if you use wxWidgets 3.0.
On Mac OS, wxWidgets 3.1 is normally used because the versions before that have a lot of wxWidgets known bugs on Mac.

Tim S.
Title: Re: Compiling 17.12 on Linux - best to use wx 2.8? 3.0? or 3.1?
Post by: awake on January 06, 2018, 06:17:15 pm
So, sounds like it is best to use wx3.0 for compiling c:b on Linux. But if jens' updated .deb files work, it may be a moot point for me ...