Code::Blocks

Developer forums (C::B DEVELOPMENT STRICTLY!) => Contributions to C::B => Topic started by: younes_ysf on February 25, 2017, 05:42:57 pm

Title: C::B not runnig under openSUSE Tumblewe:Fatal Error: Mismatch between...
Post by: younes_ysf on February 25, 2017, 05:42:57 pm
hi to all
i have installed this IDE using 1click install in this page:
https://software.opensuse.org/package/codeblocks (https://software.opensuse.org/package/codeblocks)
devel:tools:ide and it installed but didn't worked
i tried to run it with terminal command: codeblocks but it gave me this error:

Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1010,wx containers,compatible with 2.6).
Aborted (core dumped)

i removed the codeblocks by selecting anything that has codeblocks in its name and installed it again with option number 2

home:NarkoZ:Nightlies
but again the same problem.
i searched the net and forum but i couldn't solve my problem.
 i am new to Linux. i didn't compiled anything just clicking and installing using  YaST install/remove software.
how i can make it work?
thanks in advance.