Code::Blocks

User forums => General (but related to Code::Blocks) => Topic started by: Psyche on September 13, 2016, 08:39:06 pm

Title: Please help me solve this issue
Post by: Psyche on September 13, 2016, 08:39:06 pm
Hi! I'm having a problem with codeblocks. Whenever I run a program after coding it shows a blank window. Even if i run a simple program like Hello World it runs and  then a blank screen appears.
Can anyone tell me what i should do to solve this problem? :-[
Title: Re: Please help me solve this issue
Post by: stahta01 on September 13, 2016, 09:02:21 pm
The version of Windows might make a difference; OS Version?

Any reason you are NOT using Code::Blocks version 16.01?

Tim S.
Title: Re: Please help me solve this issue
Post by: Psyche on September 13, 2016, 09:24:49 pm
I'm using windows 10.
Ok i uninstalled the previous version and installed the 16.01 version. Still it's showing the same thing.
Title: Re: Please help me solve this issue
Post by: oBFusCATed on September 13, 2016, 10:19:35 pm
What happens if you open a cmd.exe and run the same executable in it?
Title: Re: Please help me solve this issue
Post by: Psyche on September 13, 2016, 10:25:46 pm
Nothing happens  :-\
Title: Re: Please help me solve this issue
Post by: stahta01 on September 13, 2016, 10:37:54 pm
Have you checked for an Anti-Virus issue?

Because, this sounds like either bad code or Anti-Virus program is causing the problem to me.

Tim S.
Title: Re: Please help me solve this issue
Post by: Psyche on September 14, 2016, 05:26:23 pm
Turns out it was an antivirus issue  ::)
Disabled avast and it works again! :D
Thanks!
Title: Re: Please help me solve this issue
Post by: BlueHazzard on September 14, 2016, 09:53:14 pm
http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_(general)#Q:_I_get_a_blank_.28black.29_terminal_window_on_windows