Code::Blocks

User forums => Nightly builds => Topic started by: killerbot on August 01, 2015, 10:49:19 am

Title: The 01 August 2015 build (10376) is out.
Post by: killerbot on August 01, 2015, 10:49:19 am
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

Before you use a nightly make sure you understand how it works (http://forums.codeblocks.org/index.php/topic,3232.0.html).

A link to the unicode windows wxWidget dll for Code::Blocks : http://sourceforge.net/projects/codeblocks/files/Binaries/Nightlies/Prerequisites/wxmsw28u_gcc_cb_wx2812_gcc492-TDM.7z

For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://sourceforge.net/projects/codeblocks/files/Binaries/Nightlies/Prerequisites/mingwm10_gcc492-TDM.7z

The 01 August 2015 build is out.
  - Windows :
   http://sourceforge.net/projects/codeblocks/files/Binaries/Nightlies/2015/CB_20150801_rev10376_win32.7z
  - Linux :
   none

The current SDK version is : 1.25.0

Resolved Fixed:


Regressions/Confirmed/Annoying/Common bugs:


Title: Re: The 01 August 2015 build (10376) is out.
Post by: jens on August 01, 2015, 12:25:21 pm
Debian packages (binaries and sources) for 32-bit and 64-bit systems can be found in my debian-repo (https://apt.jenslody.de/).
These packages are build against wxWidgets 3.0 from Debian repos and mght not be as stable than the versions build against wx2.8, but there are no wx2.8 packages available (at least for stable) from official repos.
Please test and give feedback.

Currently compiling, will soon be uploaded.

Fedora packages (binaries and sources) for 32-bit and 64-bit systems (fc20, fc21, fc22 and rawhide), RedHat/CentOS 5 and 6 packages (also 32-bit and 64-bit) and RedHat/CentOS 7 packages (only 64-bit at the moment) can be found in my rpm-repo (https://copr.fedoraproject.org/coprs/jenslody/).
I recently switched to copr (https://copr.fedoraproject.org/) to build and host my Fedora and CentOS packages.
Instructions how to use it can be found on my server (https://rpm.jenslody.de/) (easier) or on copr (https://copr.fedoraproject.org/coprs/jenslody/) (a little more handwork needed).
Title: Re: The 01 August 2015 build (10376) is out.
Post by: oBFusCATed on August 01, 2015, 01:23:37 pm
Russian spelling is not working ...  :'(
You're posting in the wrong topic...
Title: Re: The 01 August 2015 build (10376) is out.
Post by: shurick on August 02, 2015, 07:09:24 am
Packages for openSUSE (http://codeblocks.esy.es) (binaries and sources) for 32-bit and 64-bit.
Title: Re: The 01 August 2015 build (10376) is out.
Post by: cacb on August 02, 2015, 02:11:43 pm
Debian packages (binaries and sources) for 32-bit and 64-bit systems can be found in my debian-repo (https://apt.jenslody.de/).
These packages are build against wxWidgets 3.0 from Debian repos and mght not be as stable than the versions build against wx2.8, but there are no wx2.8 packages available (at least for stable) from official repos.
Please test and give feedback.

I have tried to build this nightly from source using the same method I have applied many times before, but now I am having some problems building:


- OS: Kubuntu 14.10 64bit
- CB source: https://apt.jenslody.de/stable/pool/main/codeblocks_13.12svn10376.orig.tar.gz
- extracted all the files to a folder on an ext4 formatted partition
- added  "--with-wx-config=/usr/bin/wx-config" to the DEB_CONFIGURE_EXTRA_FLAGS in debian/rules
- issued "sudo dpkg-buildpackage" to compile all packages


This procedure has worked fine for a couple of years, but now I am getting the following error after some time. I am trying to build against official wx-2.8 as i have done before

$ /usr/bin/wx-config --list
  Default config is gtk2-unicode-release-2.8 

  Alternate matches:
    base-unicode-debug-2.8
    base-unicode-release-2.8
    gtk2-unicode-debug-2.8


All compilation and linking seems to work, but the generation of .deb files fail:

...
# only call dh_scour for packages in main
if grep -q '^Component:[[:space:]]*main' /CurrentlyBuilding 2>/dev/null; then dh_scour -plibwxsmithlib0 ; fi
dh_md5sums -plibwxsmithlib0
dh_builddeb -plibwxsmithlib0 -- -Zlzma
dpkg-deb: warning: deprecated compression type 'lzma'; use xz instead
dpkg-deb: warning: ignoring 1 warning about the control file(s)
dpkg-deb: building package `libwxsmithlib0' in `../libwxsmithlib0_13.12svn0_amd64.deb'.
dh_gencontrol -plibwxsmithlib0-dev 
# only call dh_scour for packages in main
if grep -q '^Component:[[:space:]]*main' /CurrentlyBuilding 2>/dev/null; then dh_scour -plibwxsmithlib0-dev ; fi
dh_md5sums -plibwxsmithlib0-dev
dh_builddeb -plibwxsmithlib0-dev -- -Zlzma
dpkg-deb: warning: deprecated compression type 'lzma'; use xz instead
dpkg-deb: warning: ignoring 1 warning about the control file(s)
dpkg-deb: building package `libwxsmithlib0-dev' in `../libwxsmithlib0-dev_13.12svn0_amd64.deb'.
dh_gencontrol -pwxsmith-dev 
# only call dh_scour for packages in main
if grep -q '^Component:[[:space:]]*main' /CurrentlyBuilding 2>/dev/null; then dh_scour -pwxsmith-dev ; fi
dh_md5sums -pwxsmith-dev
dh_builddeb -pwxsmith-dev -- -Zlzma
dpkg-deb: warning: deprecated compression type 'lzma'; use xz instead
dpkg-deb: warning: ignoring 1 warning about the control file(s)
dpkg-deb: building package `wxsmith-dev' in `../wxsmith-dev_13.12svn0_amd64.deb'.
dpkg-genchanges  >../codeblocks_13.12svn10112_amd64.changes
dpkg-genchanges: error: cannot read ../codeblocks_13.12svn0.dsc: No such file or directory
dpkg-buildpackage: error: dpkg-genchanges gave error exit status 2


Any advice on this? 

Not sure what "dpkg-genchanges" tries to do...


Update:
I observe another symptom with this build, svn number is zero
Previously, I got: codeblocks-common_13.12svn10090_all.deb  (for build 10090)
This build, I got: codeblocks-common_13.12svn0_all.deb (for build 10376)
and the same for all others
Title: Re: The 01 August 2015 build (10376) is out.
Post by: jens on August 02, 2015, 05:41:05 pm
I know the cause, I look into it and see if it can be fixed easily.
Title: Re: The 01 August 2015 build (10376) is out.
Post by: stahta01 on August 03, 2015, 05:27:02 pm
Jens: Your links in your sign are NOT working for me.

Example: https://apt.jenslody.de/ (https://apt.jenslody.de/)

Edit2: The links just started working for me.

Tim S.
Title: Re: The 01 August 2015 build (10376) is out.
Post by: jens on August 04, 2015, 06:26:53 pm
@cacb:
Can you test it with the actual source (https://apt.jenslody.de/stable/pool/main/codeblocks_13.12svn10379.orig.tar.gz) ?
Title: Re: The 01 August 2015 build (10376) is out.
Post by: jens on August 04, 2015, 06:28:07 pm
Jens: Your links in your sign are NOT working for me.

Example: https://apt.jenslody.de/ (https://apt.jenslody.de/)

Edit2: The links just started working for me.

Tim S.
Hi Tim,
I know, it was a short unplanned downtime.
Title: Re: The 01 August 2015 build (10376) is out.
Post by: cacb on August 04, 2015, 09:20:19 pm
@cacb:
Can you test it with the actual source (https://apt.jenslody.de/stable/pool/main/codeblocks_13.12svn10379.orig.tar.gz) ?

Thanks for the follow up! Now I got a bit further, looks like all .debs build properly. However, "sudo dpkg-buildpackage" ended like this:

# only call dh_scour for packages in main
if grep -q '^Component:[[:space:]]*main' /CurrentlyBuilding 2>/dev/null; then dh_scour -pwxsmith-dev ; fi
dh_md5sums -pwxsmith-dev
dh_builddeb -pwxsmith-dev
dpkg-deb: building package `wxsmith-dev' in `../wxsmith-dev_13.12svn10379_amd64.deb'.
 dpkg-genchanges  >../codeblocks_13.12svn10379_amd64.changes
dpkg-genchanges: including full source code in upload
 dpkg-source --after-build codeblocks-13.12svn
dpkg-buildpackage: full upload; Debian-native package (full source is included)
 signfile codeblocks_13.12svn10379.dsc
gpg: WARNING: unsafe ownership on configuration file `/home/ca/.gnupg/gpg.conf'
gpg: skipped "Jens Lody <[email protected]>": No secret key
gpg: [stdin]: clearsign failed: No secret key

dpkg-buildpackage: error: failed to sign .dsc and .changes file


Apparently the above is a just minor issue. I had an install script that had issues resolving all dependencies, I therefore ended up stripping it down to include what I believe would be a "user-only, not cb-developer subset". My install script looks like this:

#!/bin/bash
#
# Script to install Code::Blocks build * from local packages
# run as follows: $ sudo ./install_cb.sh
#
VER='13.12'
SVNNR='svn10379'
CPUCFG='amd64'

echo "------------------------------------------------------------------------------"
echo "--------- Code::Blocks install script BEGIN: " codeblocks-${SVNNR}_${CPUCFG} "-------"
echo "------------------------------------------------------------------------------"

dpkg -i \
libcodeblocks0_${VER}${SVNNR}_${CPUCFG}.deb \
libwxsmithlib0_${VER}${SVNNR}_${CPUCFG}.deb \
codeblocks_${VER}${SVNNR}_${CPUCFG}.deb \
codeblocks-common_${VER}${SVNNR}_all.deb \
codeblocks-libwxcontrib0_${VER}${SVNNR}_${CPUCFG}.deb \
codeblocks-contrib-common_${VER}${SVNNR}_all.deb \
codeblocks-contrib_${VER}${SVNNR}_${CPUCFG}.deb

apt-get -f install
dpkg-reconfigure codeblocks
dpkg-reconfigure codeblocks-contrib

echo "------------------------------------------------------------------------------"
echo "--------- Code::Blocks install script END: Please check for possible errors --"
echo "------------------------------------------------------------------------------"



This seems to work fine, I have svn10379 running just fine, and it looks to be more responsive than before. Great job!

Title: Re: The 01 August 2015 build (10376) is out.
Post by: jens on August 04, 2015, 09:28:13 pm
There is no need to run dpkg-buildpackage as root.
It uses fakeroot internally and works just fine (as long as the normal user is allowed to write into the source-tree and one folder below).
Title: Re: The 01 August 2015 build (10376) is out.
Post by: cacb on August 04, 2015, 11:07:52 pm
There is no need to run dpkg-buildpackage as root.
It uses fakeroot internally and works just fine (as long as the normal user is allowed to write into the source-tree and one folder below).

Thank you. I tested it, and it builds without sudo. The warning about "unsafe ownership" is gone. Otherwise the same as before, including the final gpg error.
Title: Re: The 01 August 2015 build (10376) is out.
Post by: jens on August 04, 2015, 11:25:17 pm
There is no need to run dpkg-buildpackage as root.
It uses fakeroot internally and works just fine (as long as the normal user is allowed to write into the source-tree and one folder below).

Thank you. I tested it, and it builds without sudo. The warning about "unsafe ownership" is gone. Otherwise the same as before, including the final gpg error.
The gpg-error might go away if you change or remove the "Maintainer: ..."-line in "debian/control", but I'm not absolutely sure. I do not use Debian myself since several years, just maintain the packages on my (CentOS-)server.
Title: Re: The 01 August 2015 build (10376) is out.
Post by: cacb on August 05, 2015, 08:46:26 am
The gpg-error might go away if you change or remove the "Maintainer: ..."-line in "debian/control", but I'm not absolutely sure. I do not use Debian myself since several years, just maintain the packages on my (CentOS-)server.

Ok, I will test it and report back. Thanks a lot.
Title: Re: The 01 August 2015 build (10376) is out.
Post by: cacb on August 05, 2015, 08:03:05 pm
The gpg-error might go away if you change or remove the "Maintainer: ..."-line in "debian/control", but I'm not absolutely sure. I do not use Debian myself since several years, just maintain the packages on my (CentOS-)server.

Ok, I will test it and report back. Thanks a lot.

I tried first removing the whole "Maintainer: ..." line, I got this at the end

dh_builddeb -pwxsmith-dev
dpkg-deb: warning: parsing file 'debian/wxsmith-dev/DEBIAN/control' near line 30 package 'wxsmith-dev':
 missing maintainer
dpkg-deb: warning: ignoring 1 warning about the control file(s)
dpkg-deb: building package `wxsmith-dev' in `../wxsmith-dev_13.12svn10379_amd64.deb'.
 dpkg-genchanges  >../codeblocks_13.12svn10379_amd64.changes
dpkg-genchanges: including full source code in upload
dpkg-genchanges: error: missing information for critical output field Maintainer
dpkg-buildpackage: error: dpkg-genchanges gave error exit status 255


Then I left the "Maintainer: ..." line in, but removed your name/email. I still got some complaints at the end:

dpkg-deb: warning: ignoring 1 warning about the control file(s)
dpkg-deb: building package `wxsmith-dev' in `../wxsmith-dev_13.12svn10379_amd64.deb'.
 dpkg-genchanges  >../codeblocks_13.12svn10379_amd64.changes
dpkg-genchanges: including full source code in upload
 dpkg-source --after-build codeblocks-13.12svn
dpkg-buildpackage: full upload; Debian-native package (full source is included)
 signfile codeblocks_13.12svn10379.dsc
gpg: skipped "Jens Lody <[email protected]>": No secret key
gpg: [stdin]: clearsign failed: No secret key


I can still install/run CB.

Title: Re: The 01 August 2015 build (10376) is out.
Post by: teto on August 13, 2015, 12:57:16 pm
I was using the ubuntu repository from ppasguy but as my nightly was getting old, I moved back  to Jens' repostiory even though there is a big WxWidget 3 warning.

Parts of the codeblocks window often don't get drawn, either the toolbar or the the tabs or the source code, any part really. Is that an artefact on my machine( Ubuntu 15.04) or is it related to the warning ?

Cheers
Title: Re: The 01 August 2015 build (10376) is out.
Post by: stahta01 on August 14, 2015, 05:40:24 am
I was using the ubuntu repository from ppasguy but as my nightly was getting old, I moved back  to Jens' repostiory even though there is a big WxWidget 3 warning.

Parts of the codeblocks window often don't get drawn, either the toolbar or the the tabs or the source code, any part really. Is that an artefact on my machine( Ubuntu 15.04) or is it related to the warning ?

Cheers

I just tried Jen's 10379 and got this in "Code::Blocks" log tab.

Code: [Select]
Scanning for plugins in /usr/lib/codeblocks/plugins
Manager failed to load XRC resource '/usr/share/codeblocks/EditorConfig.zip'.
Manager failed to load XRC resource '/usr/share/codeblocks/headerfixup.zip'.
Manager failed to load XRC resource '/usr/share/codeblocks/Cscope.zip'.
Tools Plus Plugin: Registering shell type Piped Process Control
Manager failed to load XRC resource '/usr/share/codeblocks/ToolsPlus.zip'.
Manager failed to load XRC resource '/usr/share/codeblocks/wxSmithAui.zip'.
Manager failed to load XRC resource '/usr/share/codeblocks/ThreadSearch.zip'.
Manager failed to load XRC resource '/usr/share/codeblocks/Valgrind.zip'.
Manager failed to load XRC resource '/usr/share/codeblocks/Cccc.zip'.
Manager failed to load XRC resource '/usr/share/codeblocks/CppCheck.zip'.
Manager failed to load XRC resource '/usr/share/codeblocks/DoxyBlocks.zip'.
Loaded 57 plugins

Tim S.
Title: Re: The 01 August 2015 build (10376) is out.
Post by: stahta01 on August 15, 2015, 01:53:19 am
Opened a thread for problems using Jen's  Debian Packages.

http://forums.codeblocks.org/index.php/topic,20507.0.html (http://forums.codeblocks.org/index.php/topic,20507.0.html)

Tim S.