Code::Blocks

Developer forums (C::B DEVELOPMENT STRICTLY!) => Plugins development => Topic started by: threeS on October 17, 2014, 11:00:14 pm

Title: Can't install Plugin
Post by: threeS on October 17, 2014, 11:00:14 pm
I installed my plugin but it gives me a warning like
Quote
One or more plugins were not loaded. This usually happens when a plugin is built for a different version of the Code::Blocks SDK.
Check the application log for more info.
and where i can find the application log?

Thank you for the help  :)
Title: Re: Can't install Plugin
Post by: stahta01 on October 17, 2014, 11:50:01 pm
I believe that is the log window titled "Code::Blocks" on my PC it is the rightmost log window.

Tim S.
Title: Re: Can't install Plugin
Post by: threeS on October 17, 2014, 11:57:45 pm
Quote
log window titled "Code::Blocks" on my PC it is the rightmost log window
Im using ubuntu OS and it shows it is in the leftmost log window, but anyways thanks!

the error says
Quote
plugin.so: not loaded (missing symbols?)

BTW, it happens when we put postgres query in the plugin code (#include <postgresql/libpq-fe.h>)
Title: Re: Can't install Plugin
Post by: oBFusCATed on October 18, 2014, 12:35:03 am
Use -Wl,--no-undefined or -z defs in the linker options and you'll see what you're doing wrong.