Code::Blocks

User forums => Embedded development => Topic started by: twgray on March 30, 2013, 12:02:58 am

Title: MSP430 support in Linux...
Post by: twgray on March 30, 2013, 12:02:58 am
When are you guys going to implement the MSP430 patch for Linux support to the daily builds?  I am, even 2 years later, still having to do patch every upgrade.  What is the holdup?
Title: Re: MSP430 support in Linux...
Post by: oBFusCATed on March 30, 2013, 11:43:15 am
What patch?
Title: Re: MSP430 support in Linux...
Post by: twgray on March 30, 2013, 05:43:21 pm
There was a patch posted here on the forum 2 years ago that adds the same support for the MSP430 to the Linux build as the Windoze build already has.  Aren't there any Linux Codeblocks users out there?
Title: Re: MSP430 support in Linux...
Post by: oBFusCATed on March 30, 2013, 07:51:45 pm
I suppose you have the patch just post it and we can talk about it.
The chance of finding another linux msp430 user here is small.
Title: Re: MSP430 support in Linux...
Post by: extraterrestrial on March 31, 2013, 07:59:34 pm
There was a patch posted here on the forum 2 years ago that adds the same support for the MSP430 to the Linux build as the Windoze build already has.  Aren't there any Linux Codeblocks users out there?
if you need it, say me
i have it for 12.11
Title: Re: MSP430 support in Linux...
Post by: richarddsmith on April 05, 2013, 10:10:31 pm
I am also an MSP430 user of CodeBlocks so the chance of finding another linux msp430 user are NOT so small afterall.
Title: Re: MSP430 support in Linux...
Post by: oBFusCATed on April 05, 2013, 11:09:54 pm
Okay, but I don't see any patch posted...
Title: Re: MSP430 support in Linux...
Post by: twgray on April 15, 2013, 11:36:52 pm
I could post a 3 year old patch, or the maintainers could just synchronize the Linux and Mac ports to the Winblows.  Are you saying you don't believe the userbase for Linux and Mac are large enough to warrant this effort?  I find that hard to believe.
Title: Re: MSP430 support in Linux...
Post by: Alpha on April 15, 2013, 11:59:50 pm
The compiler plugin has received many changes between 12.11 and now.  Just looking at the drop down, I see an entry for 'GNU GCC Compiler for MSP430'... are there further changes necessary?  (Try the nightly, if you have not yet.)
Title: Re: MSP430 support in Linux...
Post by: oBFusCATed on April 16, 2013, 12:57:03 am
I could post a 3 year old patch, or the maintainers could just synchronize the Linux and Mac ports to the Winblows.  Are you saying you don't believe the userbase for Linux and Mac are large enough to warrant this effort?  I find that hard to believe.
I find it hard to believe that you don't want to post a working patch and let us review it, fix it and then commit it.
But you want us start from scratch to integrate a compiler/wizard we don't use or care much about?

Sorry, but this is not the way open source works.

And I'm not sure what is the problem and what needs to be done. Really!
You're talking about some patch, but I haven't seen it. You're not saying what we have to fix or add.

Please help us help you. It is that simple.
Title: Re: MSP430 support in Linux...
Post by: stahta01 on April 16, 2013, 01:19:58 am
I could post a 3 year old patch, or the maintainers could just synchronize the Linux and Mac ports to the Winblows.  Are you saying you don't believe the userbase for Linux and Mac are large enough to warrant this effort?  I find that hard to believe.

You are acting like a troll; post the patch or describe the issue, or I will consider you to a complete and total troll.

Tim S.
Title: Re: MSP430 support in Linux...
Post by: twgray on April 16, 2013, 02:03:48 am
No trolling here.  Attached is the patch and the wizard for MSP430.  As I said, it is about 2 or 3 years old, and I have just been manually patching.

I have tried the nightly builds, but there is still no MSP430 support for Linux or Mac.
Title: Re: MSP430 support in Linux...
Post by: stahta01 on April 16, 2013, 02:16:50 am
FYI:

I will work on Cleaning up the patch; the patch was very poorly done.
No reason everyone waste time on it.

I am going to fix the tab/space issue and apply to patch to SVN version 7447.

After, I reduce the not needed changes I will re-post the patch.

Tim S.
Title: Re: MSP430 support in Linux...
Post by: stahta01 on April 16, 2013, 04:16:47 am
Updated patches so they apply on without extra stuff on CB SVN Version 7447.

NOTE: CB SVN  7447 fails to compile on Windows; will try later apply patches to CB 12.11.

codeblocks_svn_7447_compilerGNUMSP430_options.patch contains the compiler options for other MCUs.
(This part required the most changes; and I might have missed something.) NOTE: This patch is NOT likely valid for trunk.

codeblocks_svn_7447_Enable_msp430_under_Linux.patch enables msp430 under Linux; likely already done in trunk.

codeblocks_svn_7447_Wizard_for_msp430.patch contains the Wizard for msp430.

msp430_png.7z contains the png files needed by the msp430 Wizard.
(src/plugins/scriptedwizard/resources/msp430)


EDIT: I did NOT really check over the MSP430 Wizard code enough to say its safe or valid.

EDIT2: Created patch that applies to trunk for the wizard codeblocks_svn_trunk_Wizard_for_msp430.patch
Removed codeblocks_svn_7447_Wizard_for_msp430.patch


Tim S.
Title: Re: MSP430 support in Linux...
Post by: stahta01 on April 16, 2013, 05:31:02 am
Attached file codeblocks_svn_trunk_Wizard_for_msp430.patch.

msp430_png.7z contains the png files needed by the msp430 Wizard.
(src/plugins/scriptedwizard/resources/msp430)


NOTE: I did NOT really check over the MSP430 Wizard code enough to say its safe or valid.

Tim S.
Title: Re: MSP430 support in Linux...
Post by: stahta01 on April 16, 2013, 08:23:17 am
codeblocks_svn_7447_compilerGNUMSP430_options.patch contains the compiler options for other MCUs.
(This part required the most changes; and I might have missed something.) NOTE: This patch is NOT likely valid for trunk.
Tim S.

Created patch that adds the MCU options to trunk; needs tested.
I do NOT have an working MSP430 compiler.

Tim S.
Title: Re: MSP430 support in Linux...
Post by: stahta01 on April 16, 2013, 08:28:47 am
@twgray:

I am NOT a Code::Blocks Dev.

You need to test the updated patches; I attached to my posts.

And, if they work you need to submit them to the Code::Blocks patch site.

http://developer.berlios.de/patch/?group_id=5358 (http://developer.berlios.de/patch/?group_id=5358)

I am done doing anything more with this issue.

NOTE: Do NOT combine them back into a single patch; the CB Devs like small single issue patches!

Tim S.
Title: Re: MSP430 support in Linux...
Post by: twgray on April 20, 2013, 07:11:50 pm
I am running SVN nightly 8993 and there is NO support for MSP430 so your patch won't work with it.  I'll go and get the 7447 tag and check it out.
Title: Re: MSP430 support in Linux...
Post by: oBFusCATed on April 20, 2013, 07:30:43 pm
twgray: Have you tried to apply the patch over SVN HEAD?