Code::Blocks

Developer forums (C::B DEVELOPMENT STRICTLY!) => Plugins development => Topic started by: Cryogen on July 20, 2010, 04:48:35 am

Title: Fixed wxSmith property grid bug
Post by: Cryogen on July 20, 2010, 04:48:35 am

 Hi Guys,

I fixed a bug that has existed in wxSmith since wxPropertyGrid 1.4 was introduced. The grid view always defaults to the events page, now, and when you select the property page the divider is positioned way over on the left. See the attached pics for a sample. The bug was present on Linux and Windows and I have checked that the fix works on both. It seems to be due to either a change in behaviour in wxPropertyGrid or some code that was lost in the change over. Since I can't detect any evidence of the latter I think it's due to the former.

The fix requires only very minor changes. A change to the default grid style and a line to restore the view to the property page after constructing the events page.

Patch attached.

Cheers,

  Cryo.
Title: Re: Fixed wxSmith property grid bug
Post by: oBFusCATed on July 20, 2010, 09:23:21 am
Doesn't this always switch to the properties tab?
I've made a patch that remembers the selected tab, but I've no time to finish and test it.
I hope I can do some work on it in the next couple of days...
Title: Re: Fixed wxSmith property grid bug
Post by: Cryogen on July 20, 2010, 06:53:58 pm
Doesn't this always switch to the properties tab?
I've made a patch that remembers the selected tab, but I've no time to finish and test it.
I hope I can do some work on it in the next couple of days...

Yes it does. Cool. :-)