Code::Blocks

User forums => Help => Topic started by: SlpCtrl on September 05, 2009, 08:27:01 pm

Title: Can't build and run
Post by: SlpCtrl on September 05, 2009, 08:27:01 pm
I installed and tried to write a program, and when I hit run it would say the project is not built yet, would you like to build? If I select yes, it does nothing. If I select build and run, it does nothing. I've uninstalled and reinstalled, nothing. I've never and still don't have this problem on my desktop, only on my laptop. Can anyone help me please?  :?
Title: Re: Can't build and run
Post by: SlpCtrl on September 05, 2009, 08:53:09 pm
Also, when I even make a new console project, it STILL won't build/compile or run at all even from that (I had searched and that was the advice that I seem to have found). I've used codeblocks a lot before; I know how to use the software, I think it's the version but I just for the life of me can not get anything to compile or run at all.  :shock:
Title: Re: Can't build and run
Post by: MortenMacFly on September 05, 2009, 09:31:16 pm
What version did you install, what platform, what OS? What's the exact error message in the build log? Did you forget to install a compiler after all? Is your compiler installation incomplete (e.g. you forgot to install G++ but only GCC)?
Title: Re: Can't build and run
Post by: SlpCtrl on September 06, 2009, 02:47:04 am
What version did you install, what platform, what OS? What's the exact error message in the build log? Did you forget to install a compiler after all? Is your compiler installation incomplete (e.g. you forgot to install G++ but only GCC)?

 
When it's a single source file, it says nothing at all when I try to build. When it's a console project, it will say this:
 
"firstTry - Debug" uses an invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!]. Skipping...

 
I just installed codeblocks, no compilers or debuggers; I've used code::blocks before, quite a bit actually as it was pretty much the only compiler I've used. And I've never had to install the compilers and debuggers seperately  :?. I'm confused here; but I'm explaining exactly what's happening; nothing.
Title: Re: Can't build and run
Post by: SlpCtrl on September 06, 2009, 03:03:29 am
I fixed it; what I did was I went to settings>compiler and debugger
 
selected the toolchain executables tab
 
By default (from a fresh install) the version available right now has the default folder for MinGW WRONG. It has C:/MinGW, but the actual folder where it's installed to is C:\Program Files\CodeBlocks\MinGW (for windows). I just did an auto-detect and it corrected the problem, and voila; I can now build and run.
Title: Re: Can't build and run
Post by: maokei on June 05, 2011, 05:26:27 am
Thx man this was driving me crazy for a little while :)
Title: Re: Can't build and run
Post by: kinglarry II on August 16, 2018, 09:31:25 am
why dosent that work for me then!?!?!?!?!?! >:( >:( >:( >:( >:( >:( >:( >:( >:(
Title: Re: Can't build and run
Post by: BlueHazzard on August 16, 2018, 11:41:11 am
why dosent that work for me then!?!?!?!?!?! >:( >:( >:( >:( >:( >:( >:( >:( >:(
Why do you use a 7 year old thread  ?!?!?!?!?!?!?!?!?!!?
Why do you don't add any more information, like what compiler you have installed  ?!?!?!?!?!?!?!?!?!!?
Why do you don't tell us what codeblocks version you have installed  ?!?!?!?!?!?!?!?!?!!?
Why are you angry ?!?!?!?!?!?!?!?!?!!? >:( >:( >:( >:( >:( >:( >:( >:( >:(
Why do you don't tell us what does not work? ?!?!?!?!?!?!?!?!?!!?
Why do you don't tell us any error message? ?!?!?!?!?!?!?!?!?!!?
Why is life so hard? ?!?!?!?!?!?!?!?!?!!?
Title: Re: Can't build and run
Post by: sodev on August 16, 2018, 09:45:01 pm
Don't question the king! :-X :-X :-X :-X :-X :-X :-X :-X :-X
Title: Re: Can't build and run
Post by: stahta01 on August 17, 2018, 02:24:01 am
why dosent that work for me then!?!?!?!?!?! >:( >:( >:( >:( >:( >:( >:( >:( >:(
Why is life so hard? ?!?!?!?!?!?!?!?!?!!?

Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far, the Universe is winning. -- Rick Cook
Title: Re: Can't build and run
Post by: justhelping on November 14, 2018, 03:08:35 pm
why dosent that work for me then!?!?!?!?!?! >:( >:( >:( >:( >:( >:( >:( >:( >:(
First, try re-installing and then using the Settings > Compiler > Toolchain Executables > Auto Detect compiler method. That worked 100% fine for me, and it's 2018.
For some reason, Codeblocks doesn't know where it installed the compiler, but it did install it, so that is why you need to Auto Detect. I hope this helps  :)