Code::Blocks

Developer forums (C::B DEVELOPMENT STRICTLY!) => Development => Topic started by: ollydbg on August 25, 2009, 03:31:17 am

Title: It seems the SVN rev 5742 will always occupy 50% of my CPU
Post by: ollydbg on August 25, 2009, 03:31:17 am
Today, I have build the rev 5742 from TDM-4.4.1.
But it seems when loading a project, codeblocks.exe always occupies 50% of my cpu. I suspect there are something wrong with the "encoding detection related code", but can't give the exact clue.

Any comments?
Thanks.
Title: Re: It seems the SVN rev 5742 will always occupy 50% of my CPU
Post by: blueshake on August 25, 2009, 04:38:04 am
ok,I rebuild the rev5724 from TDM-4.4.0 ,and the problem gone.
Title: Re: It seems the SVN rev 5742 will always occupy 50% of my CPU
Post by: ollydbg on August 25, 2009, 04:47:13 am
ok,I rebuild the rev5724 from TDM-4.4.0 ,and the problem gone.

rev5724 or rev5742?
Title: Re: It seems the SVN rev 5742 will always occupy 50% of my CPU
Post by: blueshake on August 25, 2009, 04:50:31 am
sorry,5742,my wrong type.
Title: Re: It seems the SVN rev 5742 will always occupy 50% of my CPU
Post by: jens on August 25, 2009, 07:00:34 am
Today, I have build the rev 5742 from TDM-4.4.1.
But it seems when loading a project, codeblocks.exe always occupies 50% of my cpu. I suspect there are something wrong with the "encoding detection related code", but can't give the exact clue.

Any comments?
Thanks.


Why do you think it's encoding detection ?
Nothing changed there, except that pure ascii files get opened with user defined default and not system-default.

Did you read this (http://forums.codeblocks.org/index.php/topic,11055.msg75452.html#msg75452) post, there seems to be a problem with TDM-4.4.1.

Oops:
I just saw you posted there also, did you try to revert TDM's gcc to check whether it's compiler or C::B related ?
Title: Re: It seems the SVN rev 5742 will always occupy 50% of my CPU
Post by: ollydbg on August 25, 2009, 07:34:20 am
Today, I have build the rev 5742 from TDM-4.4.1.
But it seems when loading a project, codeblocks.exe always occupies 50% of my cpu. I suspect there are something wrong with the "encoding detection related code", but can't give the exact clue.

Any comments?
Thanks.


Why do you think it's encoding detection ?
Nothing changed there, except that pure ascii files get opened with user defined default and not system-default.

revert to TDM 4.4.0 seems works( reported by blueshake).
I'm trying to track the bug...

In the 4.4.1 build CB:
If I disable the CC plugin, loading a file still cause 50% CPU usage.  :D