Code::Blocks

User forums => Using Code::Blocks => Topic started by: theneo on August 09, 2009, 05:46:52 am

Title: [user feedback] Things that don't work for me.
Post by: theneo on August 09, 2009, 05:46:52 am
I installed Code::Blocks on Windows 7 RTM. There are three problems that make me change to Visual C++ Express.

The first one is indention. I checked the "auto indent" checkbox in config window, but when press enter, the caret is still at the beginning of the line, not aligned with last line's indention. I think this is a bug.

The second one is, there's no "run arguments" option for the Run command. So if my console-based code needs some arguments to run, I cannot run&debug it in C::B. When writing scientific computation codes, this becomes an annoying problem, since they often need a lot of command-line arguments..

The third one is, there are times that after I click "Stop", C::B stucks in the "waiting for process 0 to stop" state(at least more than 10 secs, seems forever). I have to relauch the IDE to continue working. Is this a bug or I missed something?

Anyway, C::B is a great work, thanks, and hope my feedbacks help :)

theneo
Title: Re: [user feedback] Things that don't work for me.
Post by: stahta01 on August 09, 2009, 06:46:35 am
The second one is, there's no "run arguments" option for the Run command. So if my console-based code needs some arguments to run, I cannot run&debug it in C::B. When writing scientific computation codes, this becomes an annoying problem, since they often need a lot of command-line arguments..

Look under "Project" -> Set program args.

Don't know about the other two things.

Tim S.
Title: Re: [user feedback] Things that don't work for me.
Post by: ollydbg on August 09, 2009, 08:51:27 am

The first one is indention. I checked the "auto indent" checkbox in config window, but when press enter, the caret is still at the beginning of the line, not aligned with last line's indention. I think this is a bug.

This works fine here in trunk build C::B.
Title: Re: [user feedback] Things that don't work for me.
Post by: blueshake on August 09, 2009, 10:38:09 am
it work fine for me too.