Author Topic: space bar doesn't work  (Read 36334 times)

Offline wilbefast

  • Multiple posting newcomer
  • *
  • Posts: 16
Re: space bar doesn't work
« Reply #15 on: September 10, 2009, 07:00:06 pm »
German's not my forte  - prefer French or Italian. I had a look on Google for help and I found another (duplicate) codeblocks thread that I hadn't picked up before:

http://forums.codeblocks.org/index.php/topic,8298.0.html

ameirhaeghe suggested fiddling with keyboard setting (System > Preferences > Keyboard) so I changed a few setting and it all seems to be working now (fingers crossed I haven't broken something else though  :o)

I changed from in General "France Alternative" (default settings picked up by flash boot) to "France" and changed the Layout from something that wasn't Dell to Dell "Laptop/Notebook Inspiron" (there was no option for Vostro but I figure that's close enough).



William

Offline libfab

  • Multiple posting newcomer
  • *
  • Posts: 45
Re: space bar doesn't work
« Reply #16 on: September 13, 2009, 01:07:22 pm »
I also have the bug again due to kubuntu's new xorg.conf by-pass. As a follow-on, I tried the hal way, with no result.
There still remains the setxkbmap way (see my post above).
As a lazy (yet efficient) way out, I now integrate the setxkbmap command to my ... codeblocks.desktop icon:

right-click on icon > Application > Command > setxkbmap -option nbsp:none && codeblocks %F

Not ideal yet it works.

Offline wilbefast

  • Multiple posting newcomer
  • *
  • Posts: 16
Re: space bar doesn't work
« Reply #17 on: September 13, 2009, 02:24:35 pm »
Have you tried fiddling with the keyboard settings? It worked fine for me and I didn't even have to mess around with manually editing configuration files.

Offline libfab

  • Multiple posting newcomer
  • *
  • Posts: 45
Re: space bar doesn't work
« Reply #18 on: September 14, 2009, 09:11:10 pm »
Yes, it works your way too. On Kunbuntu the fiddling is a bit different, use:
Configuration systeme (System settings) > Region et langue   (Region and language) > Model: any generic key PC will do (I use 105 key) | Layout variant: Défaut (Default)
It's the Alternative variant that causes the bug (-variant oss and subvariants like oss_latin9). With -variant unspecified, it's OK.

Still, I wonder whether the bug is Ubuntu's, Wx's, or C::B's ...

Offline 3sv

  • Single posting newcomer
  • *
  • Posts: 6
Re: space bar doesn't work
« Reply #19 on: March 14, 2010, 06:49:32 pm »
I had also this bug with Ubuntu 9.10, 64 bit. In the beginning space bar was working ok, but it stopped for an unknown reason.
I was able to fix it just by setting my keyboard lay-out to qwerty, and then back to azerty.
Seems like it's not related to any codeblocks setting, I have deleted my ~/.codeblocks folder and that didn't changed anything.
I am also not sure if this bug pure ubuntu related. I found no other program with the same problem, and I can't reproduce the error now that its works again. Nasty.
« Last Edit: March 14, 2010, 06:51:59 pm by 3sv »

Offline c.panel

  • Multiple posting newcomer
  • *
  • Posts: 16
    • TopoCad
Re: space bar doesn't work
« Reply #20 on: August 01, 2010, 10:48:07 am »
Ubuntu with gnome on french keyboard : I have the same problem : space bar doesn't work on a freshly installed codeblock software.
-first : the installation doesn't install the build tools (c++, headers...). thus the same soft installs everything on windows (why not on linux ?)
-second : french keyboard doesn't work.

I fix the second quirks by changing the keybord map : Systeme|Preferences|Clavier and reaffecting the french keyboard. It seems that installing of codeblocks changes something here (I had installed "France" and find "France autre"?). All other applications yet seemed to work fine with keyboard.


bikepunk

  • Guest
Re: space bar doesn't work
« Reply #21 on: April 16, 2013, 11:08:38 am »
Sorry for getting this thread out of the grave, but on Ubuntu 12.04 LTS, codeblocks version 10.05 from the official repos makes this space bar problem...

Good news : upgrading to codeblocks 12.11 solved the problem.   ;)
see : http://wiki.codeblocks.org/index.php?title=FAQ-Issues_and_Workarounds#Q:_Sometime.2C_in_the_text_editor.2C_space_bar_triggers_Code_Completion.2C_how_do_I_fix_that.3F