Author Topic: (C::B interface) weird problem  (Read 5417 times)

Saker

  • Guest
(C::B interface) weird problem
« on: June 10, 2010, 02:42:23 pm »
The interface is flipped  :shock: :-


I guess it's because I have a localized "Arabic" windows -rtl as default-  , I've tried to switch back to English but still the same problem , I didn't have this problem with C::B 8

Anyone know how to fix this ?

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7253
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: (C::B interface) weird problem
« Reply #1 on: June 10, 2010, 08:10:38 pm »
I tested it here with ar_EG.UTF-8 as system-default and got the same behaviour after checking "Settings -> Environment -> View -> Internationalization" and restart of C::B.

Unchecking it made C::B show up "normal" (ltr).

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9599
Re: (C::B interface) weird problem
« Reply #2 on: June 11, 2010, 07:07:59 am »
I tested it here with ar_EG.UTF-8 as system-default and got the same behaviour after checking "Settings -> Environment -> View -> Internationalization" and restart of C::B.
Nice idea for an Easter egg, isn't it!? :lol:
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

klonkip

  • Guest
Re: (C::B interface) weird problem
« Reply #3 on: December 12, 2010, 04:19:08 pm »
since it is not well understandable:
try to check the internalization checkbox, and restart c::b.
then disable this checkbox and restart again.
it worked for me.

bladefistx2

  • Guest
Re: (C::B interface) weird problem
« Reply #4 on: December 14, 2010, 09:33:27 pm »
Thank you very much for posting this.
I went crazy trying to understand why everything looks like someone put up a mirror in front of it.
why does this rtl feature even exist? if it's for allowing the ability to customize the program so that everything is
in locale language, it's doing something wrong..

anyway allow me to emphasize that in order to fix this you must restart the C::B once after activating internationalization,
and once more after deactivating it.

happy coding...  8)