Author Topic: SegFault when opening projects  (Read 4992 times)

Offline *ptr

  • Single posting newcomer
  • *
  • Posts: 8
SegFault when opening projects
« on: August 05, 2005, 06:33:23 am »
Hi.

Just compiled C::B on Fedora 3 (and Ubuntu also), with wxGTK2.4.2.  The IDE starts normally, and if I create a new project I can compile/debug with no major problems. The problem arises when I restart the IDE, and try to reopen the same project (I try with a lot of other projects) the app give me a segfault message.... :(

./run.sh: line 5:  4405 Segmentation fault      $APP_DIR/codeblocks.exe [email protected]

Can somebody please help me?
Thx

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: SegFault when opening projects
« Reply #1 on: August 05, 2005, 04:08:30 pm »
Hmmmm
OK let's try to get rid of the problems. Try disabling the codecompletion plugin. If you can't do it without restarting (and can't restart without crashing), go to the codeblocks / share / codeblocks subdirectory. Somewhere around there should be a codecompletion.so. Rename it to

codecompletion.somethingelse, and restart codeblocks. Does the problem go away?

Offline Game_Ender

  • Lives here!
  • ****
  • Posts: 551
Re: SegFault when opening projects
« Reply #2 on: August 05, 2005, 08:47:44 pm »
I am getting this same error on Ubuntu 5.04 with GTK 2.4.2.  I will try disabling the pluggins too.  Then dive into it with valgrind when I get the time, currently without the pluggins disabled, codeblocks crashes valgrind.

Offline *ptr

  • Single posting newcomer
  • *
  • Posts: 8
Re: SegFault when opening projects
« Reply #3 on: August 08, 2005, 07:28:16 am »
Yeah rickg22, it works, many thanks.
To Game_Ender: yes, I know, on my Ubuntu system (Hoary Hedgehog 5.04), also the same problem
exists.
Thanks again guys.

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: SegFault when opening projects
« Reply #4 on: August 08, 2005, 08:06:08 pm »
OK then we have to admit that something's DEFINITELY wrong with the class browser! :(

DEVELOPERS: DEBUG! You know the procedure, run codeblocks (the "safe copy"), and open the codeblocks project. Debug main.cpp and "run to" the line after "scanforplugins". Then continue debugging, and paste the backtrace here. Thanks.