Author Topic: Debugger Plugin Feature Disappeared?  (Read 1989 times)

Max

  • Guest
Debugger Plugin Feature Disappeared?
« on: July 04, 2007, 10:56:03 pm »
Dear All,

It seems to me that an old feature of the gdb plugin is now disappeared. If I well remember, in the past,  during a debug session I can stop the running program (for example during an endless loop) clicking on "stop debugger". Then I can set some breakpoints and continue. Now (Nightly 4125 WinXP SP2) the behaviour is different. Clicking on "stop debugger" the program is immediately terminated. Below a log. Is that feature no longer supported? Or the issue is that I am using the new GDB 6.6?

That feature was useful.....

Regards

Max

Building to ensure sources are up-to-date
Build succeeded
Selecting target: Debug
Adding source dir: C:\Development\Projects\TestGenlib\
Adding source dir: C:\Development\Projects\TestGenlib\
Adding file: obj\TestGenlib.exe
Starting debugger: done
Registered new type: wxString
Registered new type: STL String
Registered new type: STL Vector
Setting breakpoints
Debugger name and version: GNU gdb 6.6
No line 38 in file "C:/Development/Projects/TestGenlib/main.c".
Debugger finished with status 1

dasdeck

  • Guest
Re: Debugger Plugin Feature Disappeared?
« Reply #1 on: July 18, 2007, 10:46:00 am »
i got the same problem. can't debug . i get no line x in file xxx error for all my breakpoints.
i tried different versions of gdb. i use minGW, i tried cygwin, but get some strange compiler errors for my project

D3CK