Author Topic: as of june 3rd wxwidget 2.6.1 was release  (Read 4678 times)

Anonymous

  • Guest
as of june 3rd wxwidget 2.6.1 was release
« on: July 01, 2005, 02:43:31 pm »
i have not look at wxwidget site in and saw that it released a new version I did not think they would do it this soon.  I think other people might have not see it also.  I sure hope that we can fix wxwidgets 2.60 problem in c::b we are falling behind.  

I would love to help more on the bug huntion on wxwidget but getting very frustartated with spending hours try to trake down bugs in codeblock cvs that in my oppion should never have to deal with such as missing flags file missing from project and what ever else i need to track down just to get it compile.

Don't get me wrong the cvs is suppost to be the latest and the greatest and is expected to have bug but i don't think pepole should make comment to cvs that will crash the build prosses.

Anonymous

  • Guest
as of june 3rd wxwidget 2.6.1 was release
« Reply #1 on: July 01, 2005, 02:57:05 pm »
In fact I saw that release a long time ago but didn't download it till yesterday.

I've already compiled it and built Code::Blocks CVS with it.

The 2.6.0 project for Code::Blocks required me to add:

* editorlexerloader.cpp/.h to sdk
* compilerOW.cpp/.h to plugins/compilergcc
* src_private.rc to src

I also had to comment the call to wxHandleFatalException in src/app.cpp 'cause it didn't get compiled by wxWidgets (it seems like it would only compile for Unix).

Another thing I had to change, in Project/Build Options, was the name of the wxWidgets library to link with (it's wx_msw-2.6 here).

Offline Ceniza

  • Developer
  • Lives here!
  • *****
  • Posts: 1441
    • CenizaSOFT
as of june 3rd wxwidget 2.6.1 was release
« Reply #2 on: July 01, 2005, 03:02:01 pm »
There's something evil going on with the site: I was pretty sure I logged in before posting but then it says I was a Guest...

Anyway, if you fix that in the project file it should compile just fine.

Remember to download zip.exe so you can create the resource files it needs.

Offline David Perfors

  • Developer
  • Lives here!
  • *****
  • Posts: 560
as of june 3rd wxwidget 2.6.1 was release
« Reply #3 on: July 01, 2005, 03:16:13 pm »
I think we al want to use wxWidgets 2.6, and I think (as said before by someone else) it would be easier when we use a sperate branche for it. And I know there is much trouble with C::B using wx2.6, but when there is no one who is hunting these problems down and fix them, it will never get used.

On the other hand, I don't know what the plans are. When the Code::Blocks 1.0 final is released soon, then we can wait with make a branch for wx2.6 until we have a stable release. Perhaps Yiannis could tell us more about this?

In my opinion we should wait with wx2.6 util we released a stable C::B final. after that is released we should make a branch for bugfixes of that stable version and use the head for wx2.6 support.
OS: winXP
Compiler: mingw
IDE: Code::Blocks SVN WX: 2.8.4 Wish list: faster code completion, easier debugging, refactoring

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4305
    • Code::Blocks IDE
as of june 3rd wxwidget 2.6.1 was release
« Reply #4 on: July 01, 2005, 03:44:52 pm »
Quote
In my opinion we should wait with wx2.6 util we released a stable C::B final. after that is released we should make a branch for bugfixes of that stable version and use the head for wx2.6 support

That's the plan, exactly.
When the 1.0 final is released we 're switching to wx2.6. Until then, we try to apply patches regarding wx2.6 C::B compilation but not much work is done on this front...
This weekend, I 'll try to update the wx2.6 related files (project files and makefiles) so that, at least, whoever choses this road meets less roadblocks ahead (as far as C::B compilation goes) ;)

Yiannis.
Be patient!
This bug will be fixed soon...