Author Topic: sorry, but i also have linker probs!  (Read 2333 times)

trifox

  • Guest
sorry, but i also have linker probs!
« on: September 04, 2006, 10:07:10 pm »
hi all, i usually know how to build an opengl application, but i used the opengl template
and made the basic app, this works fine, but when adding the glui.h and the glut.h
header files, and including the libs to the linker path, i get always this :

Switching to target: default
mingw32-g++.exe       -IC:\Programme\CodeBlocks\include -c main.cpp -o .objs\main.o
mingw32-g++.exe   -LD:\CODING_3\test4\  -LC:\Programme\CodeBlocks\lib -LD:\CODING_3\test3 -o D:\CODING_3\test4\OpenGL.exe .objs\main.o        -lglui32 -lglut32 -lglu32 -lgdi32 -luser32 -lkernel32 -lopengl32  -mwindows
.objs\main.o:main.cpp:(.text+0x1c): undefined reference to `[email protected]'
.objs\main.o:main.cpp:(.text+0x3d): undefined reference to `[email protected]'
.objs\main.o:main.cpp:(.text+0x5d): undefined reference to `[email protected]'

i cant help me anymore, what is wrong with my libs ? the named functions DO exist in the lib files, they are in the same folder as the whole project ... fiddling around with the include order does not helped me out, so what the heck i am overseeing ?

thank you for reading/answering stupid questions ...

Offline Phatency

  • Multiple posting newcomer
  • *
  • Posts: 65
Re: sorry, but i also have linker probs!
« Reply #1 on: September 04, 2006, 10:37:05 pm »
Try this:
Code: [Select]
#define GLUT_DISABLE_ATEXIT_HACK

#include "gl/glut.h"

And, this is not a general programming board. You're better off searching gamedev.net or something.