Author Topic: Linker Error...Oopsie!  (Read 3286 times)

squimmy

  • Guest
Linker Error...Oopsie!
« on: July 03, 2006, 07:02:10 pm »
Okay, I was messing about trying to get ogre working in code blocks, long story short I've given up. It doesn't really matter that ogre doesn't work but some step I took has stopped me compiling anything at all now.

A simple hello world app will compile fine, but on linking it will return:

ld.exe cannot find -l0gremain_d


I can't remember what step I took that has caused this error... so how can I fix it?

This is Code::Blocks version 1.0 RC2.

Help  is appreciated,
Thanks.
« Last Edit: July 03, 2006, 07:04:30 pm by squimmy »

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: Linker Error...Oopsie!
« Reply #1 on: July 03, 2006, 07:12:57 pm »
A simple hello world app will compile fine, but on linking it will return:

ld.exe cannot find -l0gremain_d
Very likely, you have done both of the following:
1. added the Ogremain_d library to global compiler options (so even HelloWorld links against it)
2. set up the library path incorrectly, or not set it up at all, so the linker cannot find the Ogre libs

Solution:
1. Remove Ogremain_d from the global compiler settings, instead add it to the projects that need it.
2. Add the path to where you keep your Ogre libraries to the projects that use Ogre.
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Linker Error...Oopsie!
« Reply #2 on: July 03, 2006, 08:16:49 pm »
This is Code::Blocks version 1.0 RC2.

Hello,

I would also advice you to get the latest nightly build instead of using RC2. Anyway, RC3 should not be far away :).

Best wishes,
Michael

Offline nfz

  • Multiple posting newcomer
  • *
  • Posts: 30
Re: Linker Error...Oopsie!
« Reply #3 on: July 04, 2006, 04:22:55 am »
you might want to read this too.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4305
    • Code::Blocks IDE
Re: Linker Error...Oopsie!
« Reply #4 on: July 04, 2006, 08:12:20 am »
you might want to read this too.

Actually, this is exactly what he should read :).
Be patient!
This bug will be fixed soon...