Author Topic: odd compiler behavior when compiling CB  (Read 9829 times)

sethjackson

  • Guest
Re: odd compiler behavior when compiling CB
« Reply #15 on: June 29, 2006, 03:38:10 am »
I just noticed something that might be the cause of a lot of my problems.  In the Build Options, directories tab, compilers tab of the code::block project is this directory:

$(#WX)\contrib\include

What is used from the contrib directory?  I don't have this in my wx libraries directory.  It is in my sandbox.  What is used from it, and do I need to compile anything from it before compiling CB?

jmccay

Well C::B used to use STC which was in contrib..... I don't think anything uses it now.......

Offline jmccay

  • Almost regular
  • **
  • Posts: 202
Re: odd compiler behavior when compiling CB
« Reply #16 on: June 29, 2006, 03:47:09 am »

Well C::B used to use STC which was in contrib..... I don't think anything uses it now.......

It's in the project to be built, and the contrib directory is referenced.  Also, It is where I am getting my errors.

jmccay
OS: WinXP, Win98 SE, & sometimes Linux

a little light reading from the wxWidgets 2.6.2 readme: A detailed 2000-page reference manual is supplied in HTML, PDF and Windows Help form: see the docs hierarchy.

sethjackson

  • Guest
Re: odd compiler behavior when compiling CB
« Reply #17 on: June 29, 2006, 02:21:37 pm »

Well C::B used to use STC which was in contrib..... I don't think anything uses it now.......

It's in the project to be built, and the contrib directory is referenced.  Also, It is where I am getting my errors.

jmccay

Hmm what is referencing it?

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: odd compiler behavior when compiling CB
« Reply #18 on: June 29, 2006, 04:33:47 pm »
Nothing is referencing it, and it shouldn't cause a problem. I always deleted the contrib folder after building wxWidgets, and it does not do anything.
The reason why it is still there is because in wxWidgets 2.6.2 and earlier, STC and XRC are found there, so it wouldn't otherwise be possible to build with those versions.
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline jmccay

  • Almost regular
  • **
  • Posts: 202
Re: odd compiler behavior when compiling CB
« Reply #19 on: July 04, 2006, 10:02:25 pm »
Nothing is referencing it, and it shouldn't cause a problem. I always deleted the contrib folder after building wxWidgets, and it does not do anything.
The reason why it is still there is because in wxWidgets 2.6.2 and earlier, STC and XRC are found there, so it wouldn't otherwise be possible to build with those versions.

What happened with 2.6.3?  STC still seems to be located under contrib.  Do I have to build it seperately?

jmccay
OS: WinXP, Win98 SE, & sometimes Linux

a little light reading from the wxWidgets 2.6.2 readme: A detailed 2000-page reference manual is supplied in HTML, PDF and Windows Help form: see the docs hierarchy.

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: odd compiler behavior when compiling CB
« Reply #20 on: July 04, 2006, 10:09:16 pm »
STC still seems to be located under contrib.  Do I have to build it seperately?
Yes, no.
Yes, it is still located there, no, we don't use it any more.
XRC is no longer in contrib (we do use that), so as I said, we don't need that path in 2.6.3 any more.
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline jmccay

  • Almost regular
  • **
  • Posts: 202
Re: odd compiler behavior when compiling CB
« Reply #21 on: July 04, 2006, 10:57:40 pm »
Ok.  Thank you.
OS: WinXP, Win98 SE, & sometimes Linux

a little light reading from the wxWidgets 2.6.2 readme: A detailed 2000-page reference manual is supplied in HTML, PDF and Windows Help form: see the docs hierarchy.

Offline jmccay

  • Almost regular
  • **
  • Posts: 202
Re: odd compiler behavior when compiling CB
« Reply #22 on: July 04, 2006, 11:43:39 pm »
I was just browsing/searching over at mingw users list, and it seems a patch (http://gcc.gnu.org/bugzilla/show_bug.cgi?id=20345) has been applied to fix the warnings, but I am still trying to find out more information.  The messages I found were from late 6/2006.  Hopefully, this will fix the warning problem, and I can get my hands on a copy of mingw using it.

jmccay
OS: WinXP, Win98 SE, & sometimes Linux

a little light reading from the wxWidgets 2.6.2 readme: A detailed 2000-page reference manual is supplied in HTML, PDF and Windows Help form: see the docs hierarchy.

Offline jmccay

  • Almost regular
  • **
  • Posts: 202
Re: odd compiler behavior when compiling CB
« Reply #23 on: July 11, 2006, 01:30:25 am »
I was just browsing/searching over at mingw users list, and it seems a patch (http://gcc.gnu.org/bugzilla/show_bug.cgi?id=20345) has been applied to fix the warnings, but I am still trying to find out more information.  The messages I found were from late 6/2006.  Hopefully, this will fix the warning problem, and I can get my hands on a copy of mingw using it.

jmccay

   I was just told that the patch was applied to the gcc 4.2 branch, and unfortunately, I was also told that the mingw/cygwin versions are far from stable.  So, it looks like I am going to have to turn off warnings for now.

jmccay
OS: WinXP, Win98 SE, & sometimes Linux

a little light reading from the wxWidgets 2.6.2 readme: A detailed 2000-page reference manual is supplied in HTML, PDF and Windows Help form: see the docs hierarchy.