Author Topic: The 25 march 2006 build is out.  (Read 5925 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5253
The 25 march 2006 build is out.
« on: March 25, 2006, 07:17:56 pm »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml
A link to the unicode windows wxWidget dll for Code::Blocks : http://download.berlios.de/codeblocks/wxmsw26u_gcc_cb.7z
For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://download.berlios.de/codeblocks/mingwm10.7z

For support of ansi builds, a link to the ansi windows wxWidget dll for Code::Blocks : http://download.berlios.de/codeblocks/wxmsw26_gcc_cb.7z

The 25 March 2006 build is out.
  - Windows : http://download.berlios.de/codeblocks/CB_20060325_rev2258_win32.7z
  - Linux :
         http://download.berlios.de/codeblocks/CB_20060325_rev2258_ubuntu.deb
         http://download.berlios.de/codeblocks/CB_20060325_rev2258_fc4.rpm

Resolved Fixed:

  • keybinder : wxEvent's protected member access replaced by it's public getter methods
  • Fixed broken removal of files/folders from the project tree, when the project file was in a subfolder (bug #6782)
  • (Editor is now building palette.
    Made some basic adjustment of item priorities to show them in correct order in item palette)
  • Added support for anonymous namespaces in code-completion
  • Fixed typo in LD_LIBRARY_PATH setting when running a console program
    (non-windows platforms)
  • codestat :
      - includes clean up
      - cbMessageBox
      - variable declaration points
      - preincrement
      - unix project : remove of include directive
  • Turn mouse cursor to "busy" (hourglass) while loading the editor
    settings dialog (it takes some time because it's reloading all lexers)
  • [ Patch #952 ] Project opened twice when passed in command line
  • The debugger, under non-windows platforms, can now interrupt the
    running process (i.e. break into it while it's running).
  • Codestat: The plugin configuration panel appeared in the wrong settings panel -> fixed
  • fixed a typo in include in projectmanager.cpp

Regressions/Confirmed/Annoying/Common bugs:

  • toolbar-images-not-changing-state (is a wx problem)
  • there are several issues with Code Completion (is being redesigned : work in progress)

« Last Edit: March 26, 2006, 09:54:17 pm by killerbot »

Offline Conan Kudo

  • Multiple posting newcomer
  • *
  • Posts: 111
    • Enano CMS Project
Re: The 25 march 2006 build is out.
« Reply #1 on: March 25, 2006, 07:23:30 pm »
Uhh... I am not quite sure, but I think WxWidgets just silently released the newest version! It does not say on the main page, but once you go to the download page, it shows 2.6.3 stable, as if its been released! :shock: You may want to grab it and compile C::B with it and see if the wx problems are fixed! :P A new build could be made that is linked to the new WxWidgets! Very odd... I'm grabbing a copy right now! :D

Offline yop

  • Regular
  • ***
  • Posts: 387
Re: The 25 march 2006 build is out.
« Reply #2 on: March 25, 2006, 07:27:45 pm »
From the wxWidgets site main page:
Quote
March 25th, 2006: wxWidgets 2.6.3 has been released: please see the download page for details. This is a bug fix release. Notable improvements include Mac universal binary creation with the command-line tools, Windows Mobile 5.0 support, context menu and enhanced file selector support on Windows CE, AMD 64-bit compilation on Windows, better VC++ 2005 support, and more efficient paint handling on wxGTK.
Seems you were a few minutes faster  :lol:
Life would be so much easier if we could just look at the source code.

Offline Conan Kudo

  • Multiple posting newcomer
  • *
  • Posts: 111
    • Enano CMS Project
Re: The 25 march 2006 build is out.
« Reply #3 on: March 25, 2006, 07:32:53 pm »
Awesome!!!! I actually beat the devs about the announcement!!! That is a rarity I shall cherish forever!

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2262
Re: The 25 march 2006 build is out.
« Reply #4 on: March 26, 2006, 04:19:25 pm »
We still have the 99% cpu usage loop when the conf file is missing and splash is displaying.

I had to use a backup .conf to get CB running again.

This is a killer.