Author Topic: CB looses/confuses the compiler settings  (Read 4001 times)

Offline Slammer

  • Multiple posting newcomer
  • *
  • Posts: 15
CB looses/confuses the compiler settings
« on: February 27, 2006, 04:18:51 pm »
I am using SVN version of CB, build 2088.
In my linux installation of CB I have a very serious problem with compiler settings.
I will describe exactly the steps required to reproduce the problem.
1. Erase all settings by removing .codeblocks directory.
2. Start the codeblocks program and accept as default the GCC compiler.
3. Now in Settings>Compiler and Debugger select Intel compiler, and go to Programs Tab.
4. Select Reset Defaults and accept all messages ( I dont have an ICC compiler actually, but the programs are defined to default)
5. Select the SDCC compiler and Select again Reset Defaults (accept again all defaults)
6. Press OK to save changes.
7. Open again the Settings>Compiler and Debugger, and select Programs Tab
8. Change the selected compiler, and you will see the settings to be out of order (eg. SDCC programs textboxes, contain GCC programs etc)
It seems that the program saves the settings in wrong index. The some problem happens if I try to add a new gcc crosscompiler, for example arm-elf-gcc. After setting of programs and settings, and after restarting, i get wrong settings.
I used  a previous version of CB (about 1 month older) and everything was OK.


PS: I am using Gentoo Linux, wxGTK 2.6.2
« Last Edit: February 27, 2006, 05:26:52 pm by Slammer »

Offline Andy

  • Multiple posting newcomer
  • *
  • Posts: 16
Re: CB looses/confuses the compiler settings
« Reply #1 on: March 02, 2006, 11:50:35 am »
i have a very similar problem with svn revision 2102 on getoo and amd64. another problem in addition to those mentioned above is that i can't seem to get to the compiler flags for icc at all. when i switch to icc (even after reset to defaults) only the flags for gcc are displayed.

obviously, the config file is written in some confused way, there are things like this:

Code: [Select]
<compiler>
<user_sets />
<sets>
<gcc>
<NAME>
<str>GNU GCC Compiler</str>
</NAME>
<MASTER_PATH>
<str>/opt/intel/cc/9.0</str>
</MASTER_PATH>
<C_COMPILER>
<str>icc</str>
</C_COMPILER>
<CPP_COMPILER>
<str>icpc</str>
</CPP_COMPILER>
<LINKER>
<str>icpc</str>
</LINKER>
<LIB_LINKER>
<str>ar</str>
</LIB_LINKER>
<MAKE>
<str>make</str>
</MAKE>
<DEBUGGER>
<str>idb</str>
</DEBUGGER>
.
.
.

Offline Andy

  • Multiple posting newcomer
  • *
  • Posts: 16
Re: CB looses/confuses the compiler settings
« Reply #2 on: March 04, 2006, 03:07:07 pm »
i have found that this is a problem with the comobox, i described it here:

http://forums.codeblocks.org/index.php?topic=2510.0