Author Topic: Problems with configuration  (Read 357 times)

Offline koluna

  • Multiple posting newcomer
  • *
  • Posts: 22
Problems with configuration
« on: September 10, 2020, 09:39:47 am »
Hi, guys!
I have some problems, please, help me.

Linux Mint 19.3 Tricia.
I installed CB from repository.
The options are not available in Project Build Options (only Project, not Targets).
But they are in my config!!!
Compiler settings, Linker settings, Search directories, ...
Why is it so?!

Offline Miguel Gimenez

  • Lives here!
  • ****
  • Posts: 524
Re: Problems with configuration
« Reply #1 on: September 10, 2020, 12:58:50 pm »
Did you edit the CBP file?. Can you try the attached CBP?.

Offline koluna

  • Multiple posting newcomer
  • *
  • Posts: 22
Re: Problems with configuration
« Reply #2 on: September 10, 2020, 04:42:02 pm »
Did you edit the CBP file?. Can you try the attached CBP?.
I did not edit my config...
I will try to use your file.

Offline koluna

  • Multiple posting newcomer
  • *
  • Posts: 22
Re: Problems with configuration
« Reply #3 on: September 10, 2020, 04:57:51 pm »
Thanks. Your file works. Why does it work?
There are some other errors also, but is does not matter...
I have already understood why it did not work...
I installed new CB. I opened a project. The compilers do not match in my project and in a CB config. I changed something and save Project. The project's config was corrupted...
How did I cure it? I changed "Option compiler" to "avr-gcc" in project's config...