Author Topic: Code Blocks does not build or install in CentOS 8  (Read 453 times)

Offline alexchen

  • Multiple posting newcomer
  • *
  • Posts: 63
Code Blocks does not build or install in CentOS 8
« on: June 20, 2020, 03:43:29 am »
Hi,
  I tried to install CodeBlock on CentOS 8 and it failed because there is no libwxGTK for CentOS 8

$ sudo yum install codeblocks-20.03-1.el7.x86_64.rpm codeblocks-libs-20.03-1.el7.x86_64.rpm codeblocks-contrib-20.03-1.el7.x86_64.rpm codeblocks-contrib-libs-20.03-1.el7.x86_64.rpm
[sudo] password for user:
Last metadata expiration check: 1:49:57 ago on Fri 19 Jun 2020 04:48:39 PM PDT.
Error:
 Problem 1: conflicting requests
  - nothing provides libwx_baseu-2.8.so.0()(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_baseu-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_baseu-2.8.so.0(WXU_2.8.2)(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_baseu_net-2.8.so.0()(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_baseu_net-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_baseu_xml-2.8.so.0()(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_adv-2.8.so.0()(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_aui-2.8.so.0()(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_aui-2.8.so.0(WXU_2.8.5)(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_core-2.8.so.0()(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_core-2.8.so.0(WXU_2.8.5)(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_html-2.8.so.0()(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_qa-2.8.so.0()(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_richtext-2.8.so.0()(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_xrc-2.8.so.0()(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-20.03-1.el7.x86_64
  - nothing provides wxGTK >= 2.8.0 needed by codeblocks-20.03-1.el7.x86_64
 Problem 2: conflicting requests
  - nothing provides libwx_baseu-2.8.so.0()(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_baseu-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_baseu-2.8.so.0(WXU_2.8.2)(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_baseu_net-2.8.so.0()(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_baseu_net-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_baseu_xml-2.8.so.0()(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_adv-2.8.so.0()(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_aui-2.8.so.0()(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_aui-2.8.so.0(WXU_2.8.5)(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_core-2.8.so.0()(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_core-2.8.so.0(WXU_2.8.5)(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_html-2.8.so.0()(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_qa-2.8.so.0()(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_richtext-2.8.so.0()(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_xrc-2.8.so.0()(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-libs-20.03-1.el7.x86_64
 Problem 3: conflicting requests
  - nothing provides libwx_baseu-2.8.so.0()(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_baseu-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_baseu_net-2.8.so.0()(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_baseu_net-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_baseu_xml-2.8.so.0()(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_adv-2.8.so.0()(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_aui-2.8.so.0()(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_aui-2.8.so.0(WXU_2.8.5)(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_core-2.8.so.0()(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_core-2.8.so.0(WXU_2.8.5)(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_html-2.8.so.0()(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_qa-2.8.so.0()(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_richtext-2.8.so.0()(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_xrc-2.8.so.0()(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libboost_system.so.1.53.0()(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libhunspell-1.3.so.0()(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_aui-2.8.so.0(WXU_2.8.9)(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_core-2.8.so.0(WXU_2.8.1)(64bit) needed by codeblocks-contrib-20.03-1.el7.x86_64
 Problem 4: conflicting requests
  - nothing provides libwx_baseu-2.8.so.0()(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
  - nothing provides libwx_baseu-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
  - nothing provides libwx_baseu_net-2.8.so.0()(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
  - nothing provides libwx_baseu_xml-2.8.so.0()(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
  - nothing provides libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_adv-2.8.so.0()(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_aui-2.8.so.0()(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_core-2.8.so.0()(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_html-2.8.so.0()(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_qa-2.8.so.0()(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_richtext-2.8.so.0()(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_xrc-2.8.so.0()(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
  - nothing provides libwx_gtk2u_richtext-2.8.so.0(WXU_2.8)(64bit) needed by codeblocks-contrib-libs-20.03-1.el7.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12702
    • Travis build status
Re: Code Blocks does not build or install in CentOS 8
« Reply #1 on: June 20, 2020, 11:55:07 am »
We don't provide packages for EL8, yet. Installing the packages for EL7 won't work.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline alexchen

  • Multiple posting newcomer
  • *
  • Posts: 63
Re: Code Blocks does not build or install in CentOS 8
« Reply #2 on: June 20, 2020, 11:07:26 pm »
Thanks for the information.  I tried to build everything myself, starting with wxGTK, but it failed in make right away.
Several .xbm files (for bitmaps, I guess) declare char array with values exceeding 128, e.g.
./src/gtk/bdiag.xbm:6:50: error: narrowing conversion of ‘128’ from ‘int’ to ‘char’ inside { } [-Wnarrowing]
    0x08, 0x08, 0x04, 0x04, 0x02, 0x02, 0x01, 0x01};

Is there any existing wxGTK rpm for CentOS 8 that I can use to build Code::Blocks myself?

Thanks

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12702
    • Travis build status
Re: Code Blocks does not build or install in CentOS 8
« Reply #3 on: June 21, 2020, 01:18:39 am »
Yes, use https://pkgs.org/search/?q=wxgtk3-devel but it is gtk3 base and C::B won't work too well with it. I've tried to build with the compat-wxGTK3-gtk2 but it failed to work on my virtual machine, so I've abandoned this idea.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline alexchen

  • Multiple posting newcomer
  • *
  • Posts: 63
Re: Code Blocks does not build or install in CentOS 8
« Reply #4 on: June 21, 2020, 02:03:25 am »
I was able to install the following RPM from http://download-ib01.fedoraproject.org/pub/epel/8/Everything/x86_64/
wxBase3-3.0.4-11.el8.x86_64.rpm        wxGTK3-devel-3.0.4-11.el8.x86_64.rpm  wxGTK3-media-3.0.4-11.el8.x86_64.rpm
wxBase3-devel-3.0.4-11.el8.x86_64.rpm  wxGTK3-gl-3.0.4-11.el8.x86_64.rpm     wxGTK3-webview-3.0.4-11.el8.x86_64.rpm
wxGTK3-3.0.4-11.el8.x86_64.rpm         wxGTK3-i18n-3.0.4-11.el8.noarch.rpm

I also installed a lot of prerequisites and able to build CB code.  But I encountered the following errors at rmpbuild step:
$ rpmbuild -ta codeblocks*.tar.*
error: Failed build dependencies:
   gamin-devel is needed by codeblocks-20.03.svn.12175-1.el8.x86_64
   wxGTK >= 2.8.0 is needed by codeblocks-20.03.svn.12175-1.el8.x86_64
   wxGTK-devel >= 2.8.0 is needed by codeblocks-20.03.svn.12175-1.el8.x86_64

I found the gamin-devel PRM in http://mirror.centos.org/centos/8/PowerTools/x86_64/os/Packages/gamin-devel-0.1.10-31.el8.x86_64.rpm, but the RPM spec codeblocks.spec only works with wxGTK.

I hacked codeblocks.spec.in and replaced the requirment of wxGTK to wxGTK3 and the RPM was build successfully.

But there were still issues with the contrib RPM.  I got the following errors during installation of those two RPMs:

$ sudo yum install codeblocks-contrib-20.03.svn.12175-1.el8.x86_64.rpm codeblocks-contrib-devel-20.03.svn.12175-1.el8.x86_64.rpm
[sudo] password for fmserver:
Last metadata expiration check: 1:12:30 ago on Sat 20 Jun 2020 07:11:32 PM PDT.
Error:
 Problem 1: conflicting requests
  - nothing provides libwxchartctrl.so.0()(64bit) needed by codeblocks-contrib-20.03.svn.12175-1.el8.x86_64
  - nothing provides libwxcustombutton.so.0()(64bit) needed by codeblocks-contrib-20.03.svn.12175-1.el8.x86_64
  - nothing provides libwxflatnotebook.so.0()(64bit) needed by codeblocks-contrib-20.03.svn.12175-1.el8.x86_64
  - nothing provides libwximagepanel.so.0()(64bit) needed by codeblocks-contrib-20.03.svn.12175-1.el8.x86_64
  - nothing provides libwxkwic.so.0()(64bit) needed by codeblocks-contrib-20.03.svn.12175-1.el8.x86_64
  - nothing provides libwxled.so.0()(64bit) needed by codeblocks-contrib-20.03.svn.12175-1.el8.x86_64
  - nothing provides libwxmathplot.so.0()(64bit) needed by codeblocks-contrib-20.03.svn.12175-1.el8.x86_64
  - nothing provides libwxsmithlib.so.0()(64bit) needed by codeblocks-contrib-20.03.svn.12175-1.el8.x86_64
  - nothing provides libwxspeedbutton.so.0()(64bit) needed by codeblocks-contrib-20.03.svn.12175-1.el8.x86_64
  - nothing provides codeblocks-contrib-libs(x86-64) = 20.03.svn.12175 needed by codeblocks-contrib-20.03.svn.12175-1.el8.x86_64
 Problem 2: conflicting requests
  - nothing provides libwxchartctrl.so.0()(64bit) needed by codeblocks-contrib-devel-20.03.svn.12175-1.el8.x86_64
  - nothing provides libwxcustombutton.so.0()(64bit) needed by codeblocks-contrib-devel-20.03.svn.12175-1.el8.x86_64
  - nothing provides libwxflatnotebook.so.0()(64bit) needed by codeblocks-contrib-devel-20.03.svn.12175-1.el8.x86_64
  - nothing provides libwximagepanel.so.0()(64bit) needed by codeblocks-contrib-devel-20.03.svn.12175-1.el8.x86_64
  - nothing provides libwxkwic.so.0()(64bit) needed by codeblocks-contrib-devel-20.03.svn.12175-1.el8.x86_64
  - nothing provides libwxled.so.0()(64bit) needed by codeblocks-contrib-devel-20.03.svn.12175-1.el8.x86_64
  - nothing provides libwxmathplot.so.0()(64bit) needed by codeblocks-contrib-devel-20.03.svn.12175-1.el8.x86_64
  - nothing provides libwxsmithlib.so.0()(64bit) needed by codeblocks-contrib-devel-20.03.svn.12175-1.el8.x86_64
  - nothing provides libwxspeedbutton.so.0()(64bit) needed by codeblocks-contrib-devel-20.03.svn.12175-1.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

« Last Edit: June 21, 2020, 05:25:38 am by alexchen »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12702
    • Travis build status
Re: Code Blocks does not build or install in CentOS 8
« Reply #5 on: June 21, 2020, 11:34:07 am »
You have to install all the rpm which have been built.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]