Author Topic: WIN+[key] combo is being blocked by C::B  (Read 615 times)

Offline muesli_mage

  • Single posting newcomer
  • *
  • Posts: 2
WIN+[key] combo is being blocked by C::B
« on: May 26, 2020, 04:38:15 pm »
Hallo,

re: ticket
https://sourceforge.net/p/codeblocks/tickets/969/

CodeBlocks seems to block some key combo's which include the Windows key.
Tested after disabling the Keybinder plugin but problem persists.

Cannot find any mention of keybinds in C::B which use the Windows key,
so cannot resolve the issue.

The Windows key should be reserved for operating system functions.

Does anyone have a solution for this?

Thanks

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12883
    • Travis build status
Re: WIN+[key] combo is being blocked by C::B
« Reply #1 on: May 26, 2020, 07:35:01 pm »
I've written some things to test in the ticket.
Try:
1. Older builds to see if this was a recent regression
2. Change the focus to non-editor UI
3. Remove the keybinder plugin

(I'm not using windows, so I cannot help much more)
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2265
Re: WIN+[key] combo is being blocked by C::B
« Reply #2 on: May 28, 2020, 08:07:17 pm »
Using a virgin copy of windows 10 (not running Codeblocks)
Ctrl+Win+Numlock(ON)+anyNumKeyPad key will NOT switch desktops.
Ctrl+Win+Numlock(OFF)+anyNumKeyPadArrowKey WILL behave as advertised for Windows 10.
But Numlock must be OFF to switch desktops.

This may be related to a bug in CodeBlocks 17 (and prior versions) which allowed keybindings when numlock was ON.
This bug is still in Codeblocks 20. I will fix it soon. So please remove any keybinding in CodeBlocks that were set with Numlock ON. That should solve your problem.

A keybinding that was set with numlock on will contain a non-ascii character. Like a non-english character. See image below. Use Menu->Settings->Editor->KeyboardShortcuts to remove the binding.

https://sourceforge.net/p/codeblocks/tickets/_discuss/thread/8397da107d/c53a/attachment/keybinding.png

Offline muesli_mage

  • Single posting newcomer
  • *
  • Posts: 2
Re: WIN+[key] combo is being blocked by C::B
« Reply #3 on: May 29, 2020, 01:05:20 pm »
Ctrl+Win+Numlock(ON)+anyNumKeyPad key will NOT switch desktops.

I am trying to write an app to switch desktops with combo + numpad;
to switch desktops without scrolling.
Example from desktop 1 to desktop 9 without going through 2-8 and pressing arrow key a lot of times
So there is no official Microsoft function to do this with the numpad

But Numlock must be OFF to switch desktops.

Aha,
Yes, I tried to test, and sure it was non-response specific to Numpad without NumLock.
So the issue it not C::B at all.

Thank you all for advice

I have updated the SourceForge comments but the ticket is open,
I don't know how to close the ticket to show no open issue

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2265
Re: WIN+[key] combo is being blocked by C::B
« Reply #4 on: May 29, 2020, 06:34:57 pm »
Would someone with ticket credentials please close ticket #969.

Thanks

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12883
    • Travis build status
Re: WIN+[key] combo is being blocked by C::B
« Reply #5 on: May 29, 2020, 07:42:18 pm »
I'll do it.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]