User forums > Nightly builds

The 21 May2020 build (12091) is out.

(1/1)

killerbot:
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

Before you use a nightly make sure you understand how it works.

A link to the unicode windows wxWidget dll(s) for Code::Blocks : https://sourceforge.net/projects/codeblocks/files/Binaries/Nightlies/Prerequisites/wxmsw31u_gcc_cb_wx313_2D_gcc810-mingw64.7z
A link to Mingw64 dll's needed by Code::Blocks : http://sourceforge.net/projects/codeblocks/files/Binaries/Nightlies/Prerequisites/Mingw64dlls8.1.0.7z


The 21 May 2020 build is out.
  - Windows :
   http://sourceforge.net/projects/codeblocks/files/Binaries/Nightlies/2020/CB_20200521_rev12091_win64.7z
  - Linux :
   none

The current SDK version is : 2.2.0

Resolved Fixed:


* UI: Optimize the UpdateUI code for the debugger menu and toolbars
* UI: Optimize the UpdateUI code for the compiler's menu and toolbar
* UI: Optimize even further the File menu update ui handler
* UI: Optimize the UpdateUI for the Edit menu
* UI: Restore the UpdateUI for the Edit-> Highlight mode menu
* UI: Optimize the UpdateUI for the Search menu
* UI: Optimize the UpdateUI for the View menu
* UI: Don't add a delay between UpdateUI events
* UI: Don't try to translate empty strings in ScriptingSettingsDlg (ticket #965)
* wizard: Fix a regression in the FLTK wizard (ticket #961, thanks Huy Pham)
* wizard: FLTK wizard - search for Fl.H instead of Fl.h
Regressions/Confirmed/Annoying/Common bugs:


Xaviou:
Hi

OS X version of this rev can be downloaded from my Google Drive.
There is a specific dmg file for each version of the os (10.13, 10.14 and 10.15).

32 bits version for Windows can also be found in the same place.

Debian Stretch and Buster (32 and 64 bits) can be installed from my repo.

Regards
Xav'

ccdric:
Hello,
try to build this rev with  vx3.2.3 gtk3 from codelite repo on Ubuntu 20.04.


--- Quote [email protected]:$ sudo update-alternatives --config wx-config
Il existe 5 choix pour l'alternative wx-config (qui fournit /usr/bin/wx-config).

  Sélection   Chemin                                                            Priorité  État
------------------------------------------------------------
  0            /usr/lib/x86_64-linux-gnu/wx/config/gtk3-unicode-3.1-unofficial3   318       mode automatique
  1            /usr/lib/x86_64-linux-gnu/wx/config/base-unicode-3.0               306       mode manuel
  2            /usr/lib/x86_64-linux-gnu/wx/config/base-unicode-3.1-unofficial    317       mode manuel
  3            /usr/lib/x86_64-linux-gnu/wx/config/gtk2-unicode-3.1-unofficial    318       mode manuel
  4            /usr/lib/x86_64-linux-gnu/wx/config/gtk3-unicode-3.0               309       mode manuel
* 5            /usr/lib/x86_64-linux-gnu/wx/config/gtk3-unicode-3.1-unofficial3   318       mode manuel

--- End quote ---
after :


--- Quote ---svn up -r 12091
./update_revision.sh
--- End quote ---


--- Quote ---an error occurs in dpkg-buildpkg :
[email protected]:$ dpkg-buildpackage -us -uc
dpkg-buildpackage: info: paquet source codeblocks
dpkg-buildpackage: info: version source 20.03svn12091
dpkg-buildpackage: info: distribution source UNRELEASED
dpkg-buildpackage: info: source changé par cedric <[email protected]>
dpkg-buildpackage: info: architecture hôte amd64
 dpkg-source --before-build .
dpkg-checkbuilddeps: error: Unmet build dependencies: libwxgtk2.8-dev | libwxgtk3.0-dev
dpkg-buildpackage: avertissement: dépendances de construction et conflits non satisfaits ; échec.
dpkg-buildpackage: avertissement: (Utilisez l'option -d pour forcer.)
--- End quote ---

 strange the original wxlib 3.0 from ubuntu20.04  is also installed  :


--- Quote [email protected]:$ dpkg -l | grep libwxgtk3.0
ii  libwxgtk3.0-gtk3-0v5:amd64                                  3.0.4+dfsg-15build1                        amd64        wxWidgets Cross-platform C++ GUI toolkit (GTK 3 runtime)
ii  libwxgtk3.0-gtk3-dev:amd64                                  3.0.4+dfsg-15build1                        amd64        wxWidgets Cross-platform C++ GUI toolkit (GTK 3 development)

--- End quote ---

anybody can help me ?
thanks
 

Navigation

[0] Message Index

Go to full version