Author Topic: Creation of 32-bit GTK application  (Read 547 times)

Offline tumanovalex

  • Multiple posting newcomer
  • *
  • Posts: 13
Creation of 32-bit GTK application
« on: May 15, 2020, 10:44:01 am »
Windows 10 Home. CodeBlocks 20.03 32 bit with MinGW (no setup). I tried to make the default GTK application for 32 bits and get the error.
Code: [Select]
gcc.exe -Wall -mms-bitfields -g -ID:\gtk32\include -ID:\gtk32\include\gtk-3.0 -ID:\gtk32\include\cairo -ID:\gtk32\include\gdk -ID:\gtk32\include\glib-2.0 -ID:\gtk32\lib\glib-2.0\include -ID:\gtk32\include\pango-1.0 -ID:\gtk32\lib\gtk-3.0\include -ID:\gtk32\include\atk-1.0 -ID:\gtk32\include\gdk-pixbuf-2.0 -c W:\MyProgramming\Test\cdGtkTestDiskw32\main.c -o obj\Debug\main.o
Execution of 'gcc.exe -Wall -mms-bitfields -g -ID:\gtk32\include -ID:\gtk32\include\gtk-3.0 -ID:\gtk32\include\cairo -ID:\gtk32\include\gdk -ID:\gtk32\include\glib-2.0 -ID:\gtk32\lib\glib-2.0\include -ID:\gtk32\include\pango-1.0 -ID:\gtk32\lib\gtk-3.0\include -ID:\gtk32\include\atk-1.0 -ID:\gtk32\include\gdk-pixbuf-2.0 -c W:\MyProgramming\Test\cdGtkTestDiskw32\main.c -o obj\Debug\main.o' in 'W:\MyProgramming\Test\cdGtkTestDiskw32' failed.
There are no other error messages (lack of libraries, etc.). How can I fix it?


Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2849
Re: Creation of 32-bit GTK application
« Reply #1 on: May 15, 2020, 01:55:29 pm »
Have you installed an compiler?

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7013
    • My Best Post
Re: Creation of 32-bit GTK application
« Reply #2 on: May 15, 2020, 04:17:38 pm »
You likely need to setup the Code::Blocks toolchain.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline tumanovalex

  • Multiple posting newcomer
  • *
  • Posts: 13
Re: Creation of 32-bit GTK application
« Reply #3 on: May 16, 2020, 11:28:17 pm »
Thanks for the answers, the error was in the compiler settings